Question Ryzen 7 3700x Overheating on Idle. any help?

Nov 2, 2021
7
0
10
0
hi, so i've been using Ryzen 7 3700x for like an year now and suddenly i noticed that the FPS in the games are going down and my PC restarts alot for the specific reason "CPU Overheating". as soon as i checked the temperatures, they were over 90C on Idle and i was like BRUH when i play games or do anything the temperature rises above 90C. i have tried changing Coolers too, at first i had the Stock Cooler now i use an AIO and still i cannot see any change in the temperatures whatsoever. I saw some changes after using the AIO but that too for the first week of use. I've even tried cleaning it and nothing works out for me please help.

System Specifications:

Ryzen 7 3700X - CPU
MSI MAG CORELIQUID 240R - AIO
MSI RTX 3080 Gaming X Trio - GPU
MSI X570 Pro - MoBo
32GB G.Skill - RAM
NZXT H510 - Case

 

Phaaze88

Titan
Ambassador
Lacking airflow, or fans maybe not set up correctly. A picture would help. Take the side panel off before taking the pic.
Post images with imgur.com.

"Msi Mag Coreliquid 240R"
These things have been drawing in a lot of people due to their aggressive pricing, but they have been nothing but trouble.
That 2-point mounting bracket for AM4 makes it a little easier to screw up mounting the cooler.
 
hi, so i've been using Ryzen 7 3700x for like an year now and suddenly i noticed that the FPS in the games are going down and my PC restarts alot for the specific reason "CPU Overheating". as soon as i checked the temperatures, they were over 90C on Idle and i was like BRUH when i play games or do anything the temperature rises above 90C. i have tried changing Coolers too, at first i had the Stock Cooler now i use an AIO and still i cannot see any change in the temperatures whatsoever. I saw some changes after using the AIO but that too for the first week of use. I've even tried cleaning it and nothing works out for me please help.

System Specifications:

Ryzen 7 3700X - CPU
MSI MAG CORELIQUID 240R - AIO
MSI RTX 3080 Gaming X Trio - GPU
MSI X570 Pro - MoBo
32GB G.Skill - RAM
NZXT H510 - Case
Assuming everything is mounted right, make sure pump is connected to Water_PUMP header or any sys-fan that can be set to work full speed all the time.
 
Nov 2, 2021
7
0
10
0
Lacking airflow, or fans maybe not set up correctly. A picture would help. Take the side panel off before taking the pic.
Post images with imgur.com.

"Msi Mag Coreliquid 240R"
These things have been drawing in a lot of people due to their aggressive pricing, but they have been nothing but trouble.
That 2-point mounting bracket for AM4 makes it a little easier to screw up mounting the cooler.
View: https://imgur.com/a/f6YdJNU

here.
 
Last edited:
Nov 2, 2021
7
0
10
0
That seems to be correctly installed for the AIO radiator. Are you confident the pump is running at 100% all the time though? Probably just set it on fixed 12V in fan profiles.

The clip mounting can be misleading: make sure both the thumb screws are evenly tightened AND the screws mounting the plastic clips to the backplate are also tight.
They are tight but lemme just set them on 12V
 
Nov 2, 2021
7
0
10
0
That seems to be correctly installed for the AIO radiator. Are you confident the pump is running at 100% all the time though? Probably just set it on fixed 12V in fan profiles.

The clip mounting can be misleading: make sure both the thumb screws are evenly tightened AND the screws mounting the plastic clips to the backplate are also tight.
still getting 96C on startup and so on :(
 

Phaaze88

Titan
Ambassador
well there is no front panel in H510 then what should i do?
Getting rid of it and getting something else. If you're curious enough:

1)Repaste and remount the cpu block. That 2-point mounting bracket for AM4 is harder to get correctly.
It took me a couple tries to get it right with a Fractal S28, which uses the same thing.

2)Un-secure the radiator from the chassis. Flip it upside down from how it currently appears in the chassis, and check thermals again while it is in that position.
 
Nov 2, 2021
7
0
10
0
Getting rid of it and getting something else. If you're curious enough:

1)Repaste and remount the cpu block. That 2-point mounting bracket for AM4 is harder to get correctly.
It took me a couple tries to get it right with a Fractal S28, which uses the same thing.

2)Un-secure the radiator from the chassis. Flip it upside down from how it currently appears in the chassis, and check thermals again while it is in that position.
well i can get something else but till that time i have to use what i have, i think i should rebuild the whole computer again and see if the problem still exists or not maybe i need to clean some remaining dust that's blocking and causing problem or i can just replace the things as they are still in warranty.
can you suggest me something like what should i change and what kind of things should i keep in mind while building as i am kinda noob in this part.
 
Nov 2, 2021
7
0
10
0
Deepcool AS500
Thermalright Frost Spirit 140 RGB
The Coreliquid R is just a bundle of trouble. The only ones worth bothering with are the K and S, but they're stupid expensive.
Well in my Country the prices are almost same ig for K360 but i think i am going to rework on my setup completely if nothing works out
 

ASK THE COMMUNITY

TRENDING THREADS