[SOLVED] Ryzen 7 5800X Random freezes windows 10 when gaming

Jan 5, 2022
6
2
15
0
Hi.

I'm having a issue. While gaming my PC keep crushing/freezes randomly. Sometimes it takes 10 min to freeze or it can even take like couple of hours.
I have two monitors plug into Asus RTX 2070 and while gaming I'm watching something on second screen (Youtube, Netflix etc..)
I'm not talking here about BSOD. It just freezes the USB ports?
It's always the same. I hear sound like device is unpluged and pluged again. Probably you know what I mean. The sound when system finding new device and installing drivers for it.
So it keeps doing like this 3 times continuously and after that it freezes. What I mean is: Mouse do not response, keyboard, and all other USB devices not working.
Ethernet is disconecting aswell. Just like would you unplug your ethernet cable of.
The same is happening with WIFI connection. It shows the round globe when you don't have any connectivity at all or no drivers installed.
The game is still running but I can't do sh....it. Video/Netflix on secound screen stops though.
I tried to plug it to other USB ports but no result. Then what i can do is just hard reset the PC.
After hard restet everything is fine untill again 10 to couple hours and agin the same.
It even freezes meanwhile I play Starcraft 1. Is so frustrating.

Please don't tell me that i have to update my drivers or something. I need real help.
I tried to install celan Windows 10 3-4 times already. I even changed from WIN 10 Pro to Home becasue someone advised me to do so.
I installed all drivers. Updated believe me all relevant drivers you can think of.
I updated BIOS to newst version. I disabled TPM (On some forum they said it can be that)
I clean booted it, sfcscan also.I changed power management settings. I messured power consumption in peak and it didn't even go up to 350W.
I probably done everything.
The funny thing is that in Event Viewer is nothing. No warnings no errors and no information about it.
I really do not know what to do right know so i'm comming to you for help because i know you are Masters in this stuff.

Please help me and sorry for my English.

My setup is:

Ryzen 7 5800X
Gigabyte B550 AORUS Elite V2 rev.1
32GB DDR4 HyperX Fury RGB 3200MHz CL16 4x8GB
Asus RTX 2070 8GB
Corsair VS550 PSU
Silentium PC Navis RGB 240
Samsung 970 Evo Plus 250GB for system
ADATA XPG SX8200 PRO 1TB for game's library
2x ACER 27'' monitors
Windows 10 Home

and i used Thermal Grizzly Kryonaut for CPU

I did not Overclock anything in that system.

Thanks
LB
 
Last edited:

Vic 40

Titan
Ambassador
Would start with tis for a solid base, something to power that build for not alot of money, if you want to keep spend money to a minimum, and decent enough quality,
https://pcpartpicker.com/product/B8RFf7/bitfenix-formula-gold-650w-80-gold-certified-atx-power-supply-bp-fm650ulag-7r
or 750watt,
https://pcpartpicker.com/product/Tsbkcf/bitfenix-formula-gold-750w-80-gold-certified-atx-power-supply-bp-fm750ulag-7r
which should be enough for a more high powered gpu. Not modular, but if you are prepaired to use VS series psu should that not be a problem.
Oh 650watts modular,
https://pcpartpicker.com/product/DQx9TW/bitfenix-whisper-m-650w-80-gold-certified-fully-modular-atx-power-supply-bp-wg650umag-7fm
Probable other most "cheap" option,
https://pcpartpicker.com/product/2HbwrH/corsair-rmx-2018-650w-80-gold-certified-fully-modular-atx-power-supply-cp-9020178-na

if not available let us know what country you're in. Maybe even shop you would buy.

One stick tried was in all slots?

Temperatures are good? Can use hwinfo to keep an eye on that,

download hwinfo64,
install and open it,
check "sensors-only",
click "run".
 

Vic 40

Titan
Ambassador
First have to get this of my chest, you have a Ryzen 5800X and you have a RTX 2070, you use even expensive Kryonaut for paste and you then of al things use a Corsiar VS550watt to power that?

The ram came in one kit?
 
Jan 5, 2022
6
2
15
0
Hi and thanks for reply.

The VS550 is from old built. Seems 550W is enough for it but if you have any suggestions please let me know.
And no. I bought RAM in two kits for 2x8GB.
I tried already swapping them but no effect.
I even tried with one stick of 8GB but is all the same.
 

Vic 40

Titan
Ambassador
Would start with tis for a solid base, something to power that build for not alot of money, if you want to keep spend money to a minimum, and decent enough quality,
https://pcpartpicker.com/product/B8RFf7/bitfenix-formula-gold-650w-80-gold-certified-atx-power-supply-bp-fm650ulag-7r
or 750watt,
https://pcpartpicker.com/product/Tsbkcf/bitfenix-formula-gold-750w-80-gold-certified-atx-power-supply-bp-fm750ulag-7r
which should be enough for a more high powered gpu. Not modular, but if you are prepaired to use VS series psu should that not be a problem.
Oh 650watts modular,
https://pcpartpicker.com/product/DQx9TW/bitfenix-whisper-m-650w-80-gold-certified-fully-modular-atx-power-supply-bp-wg650umag-7fm
Probable other most "cheap" option,
https://pcpartpicker.com/product/2HbwrH/corsair-rmx-2018-650w-80-gold-certified-fully-modular-atx-power-supply-cp-9020178-na

if not available let us know what country you're in. Maybe even shop you would buy.

One stick tried was in all slots?

Temperatures are good? Can use hwinfo to keep an eye on that,

download hwinfo64,
install and open it,
check "sensors-only",
click "run".
 
Jan 5, 2022
6
2
15
0
Thanks for suggestions.

I was thinking to buy RM750 or RM750x if is good idea let me know.

Ram: I tried 4 in every slots
2 in dual channel A2 and B2
1 in A2

XMP on

About the sensor I already done it with CPUID HWMonitor and everything was fine. Temp around 75C

Do you think that the PSU is the issue here?
 
Last edited:

Vic 40

Titan
Ambassador
Thanks for suggestions.

RM750x is good idea


Ram: I tried 4 in every slots
2 in dual channel A2 and B2
1 in A2

XMP on
One, turn XMP of for now, see if it will work at 2133mhz.
Two, test with one stick on slot A2. (second from the cpu out.



Do you think that the PSU is the issue here?
Cannot rule it out. Normally no, freezes and usb cutting out aren't really what you relate to a psu being a problem , motherboard would come first to mind, but with such a low quality psu do it think you need to consider this to be a problem.
 
Jan 5, 2022
6
2
15
0
Alright.

I ordered online the RM750x.
I'll have it over the weekend and then I'll check if its it.
But should'nt I get BSOD or something when PSU is no enough or is unefficient? That is just my way of thinking about it :).
Also first idea was the MB. I really hope is not.

Thanks and i'll get you after the weekend.
 
Reactions: Vic 40
Jan 5, 2022
6
2
15
0
Hi Again.

So. I replaced PSU to RM750x and on weekend I installed Win 11.
My PC started to behave diffrently. I've got BSOD now with:
DPC Watchdog Violation :(

Dump file shows ntoskrnl.exe+d05330.
I checked RAM with memtest86 and no errors.
Do know now if is some driver or something. I've got lost because i've done soo many things already.

Before BSOD appers i can say when soon it will happen because audio start to pops and glitch for a moment so i thought it maybe my Komplete Audio 6 Audio Card.
But I unpluged and no difference. Tried unistalling NVIDIA driver with unistaller and installing newest for Win11 and nothing.
I tried Verfier to run with just Windows driver but PC is sooooooooooo slow when I run it like that.

Really do not know what to do now.

Please give me any but any solution I can try out.
 
Jan 5, 2022
6
2
15
0
Ok all.
I've got a solution after I unpluded ADATA NVMe drive everyting seems to work.
The solution I reserched online was changing the PCIe Gen4 to Gen3 in BIOS.
So far for the last 3h everyting works and I hope so it will for a long time.
I'll post in the next one/two weeks if problem was solved in 100%.
Until this time please cross fingers from you all and wish me luck.

Thanks LB
 
Reactions: Vic 40

ASK THE COMMUNITY