Question Ryzen 9 3900x not working

PeRmWaZe

Honorable
May 31, 2014
10
0
10,520
1
So im beyond frustrated and very confused. I just built a new pc with the following specs.

R9 3900x
MSI X470 Gaming Pro Carbon
EVGA 750w P2 psu
2 Adata XPG nvmes
2 sata hdds
2 16gb 3200 Trident Z Royal sticks of ram
EVGA GTX 1080 SC2
And a Noctua 12a cooler

I recieved an Athlon 200GE from AMD to update my bios. And I freshly installed Windows 10 onto my first nvme.

Then I installed my 3900x and it was working beautifully for a few days. Hwinfo stated temps of 50-60 idle and upwards around 80 while under decent load. Running at 4.2-4.3 ghz all cores at stock settings.

Yesterday as I was trying to import a video into Sony Vegas. It locked up the program and although it was kind of weird I decided to let it load and walked away for about an hour. When I returned my main monitor was greyed out and my other one was black and blinking. I tried to get it to respond but couldnt so I restarted. Upon doing so the monitor, keyboard and mouse would not power on.

So I started troubleshooting.

I tried each ram stick seperately
Reseated the gpu
Checked all the connections
Unplugged and replugged in everything
Tried resetting the cmos with the button
Held the power button for 20 seconds

And had no luck. Then I noticed the cpu debugger light was on so I took out the cpu and put back in the 200GE they had sent me and sure enough after it cycled through the cpu and vga lights it booted into bios. I had to restart to get the gpu to work but once I did there was no lights on the debugger and it loaded perfectly.

At this point I cleaned my 3900x and my noctua cooler and tried to put it back in. But again it fails to boot and the cpu light is lit. At this point I think I can rule out the ram, gpu, and even the mobo. Unless the bios somehow is screwy and its suddenly not detecting the 3900x anymore. Which seems highly unlikely as the updated bios is still present.

So that just leaves the cpu or the psu. Being that the other cpu works fine and that this is a 180 dollar brand new psu I have my doubts that its that. But I suppose if its not giving enough power that the 105 tdp compared to the 35 tdp could be a possibility. Or does it just sound like my cpu is at fault here? Im running out of things to check and sadly the only other psu I have to test with is a 5 year old ran every day of its life 600w which works fine but may not be suited to test with. Since if it doesnt work I wouldnt be able to rule it out completely.

I dont want to sit around for a month trying to get an RMA from AMD. Especially if its not even the cpu. Anyone have any ideas? Thanks.
 

Lutfij

Titan
Moderator
Try removing the CMOS battery with the 3900x populating the socket(breadboarded) and replace the battery after 15 mins.

Did you create your installer for Windows 10 using Windows Media Creation Tools? You might want to reflash the BIOS with the latest BIOS update and see if your R9 3900x works. Speaking of update, which version of the BISO did you flash/update to?

Once you get the 3900x detected in BIOS, reinstall the OS with the 3900x and not the 200GE.
 

zikmir

Honorable
Jun 29, 2013
49
7
10,545
1
I just hope you didn't cook your CPU. 80c+ isn't safe as I am told. My temps were high too and I'm doing my best to figure to lower them
 
Yep your temps at idle were very high at 50 Degrees... Also as RAM seems to be a issue, have you tried booting with just one RAM stick...So remove everything other than one NVMe SSD, the boot one and just one stick of RAM and the GPU and try booting again.
 

ASK THE COMMUNITY

TRENDING THREADS