Question Ryzen 9 5900X not booting


Nov 26, 2013
Hello everyone;
Today I wanted to upgrade my CPU, from a Ryzen 5 3600 to a Ryzen 9 5900x (motherboard is gygabyte b450 gaming x )
I updated the bios to the required version, removed the old CPU, placed in the new one. It booted without issues, got into windows desktop, and then it crashed with BSOD (Stop code: WHEA UNCORRECTABLE ERROR). After this it restarted and froze on the loading screen. If I restart it, sometimes it goes into windows recovery / repair mode, saying that it wants to restore an older save point, but no matter if I click restore or cancel, on the next reset it either freezes again or just restarts the computer all over again (with no changes).

I plugged in my old R5 3600 and it booted flawlessly, it works without issues.
I tried reinstalling Windows, however it is not reading the memory stick (even with it selected as the primary boot method). The memory stick is good, I tested it on my wife's computer and it booted into windows setup with no issues. Actually, the only time it actually got into windows setup was after I tested it on that computer, then plugged it back in to mine.
If i short the CMOS, it sometimes gets into windows desktop for 2-3 seconds before crashing again.
Booting in safe mode does not change anything, it still crashes once it reaches the desktop (if it reaches it).
BIOS values are all the default values (I even reset it a few times to be sure); the previous CPU was not overclocked, and neither is the memory. Speaking of memory, I tried swapping the memory sticks, or only using one, but nothing changes.
Edit: Checked the pins, there are no issues (the CPU is brand new)

Now 1 more thing I havent tried, but cant unless I buy a new PSU: The motherboard has a 8 pin slot ATX connector for the CPU however my PSU only has 4 pin supply (no other 4 or 8 pins) ; There were no issues with the Ryzen 5 3600 however, and from what I understand there shouldnt be any issues with the 5900x. Yes, the old one has a TDP of 60w and the new one is 105w, but 4 pins should supply enough for a 155, of which I am far below.

How can I solve this ?


Did yo clear the CMOS after verifying that the BIOS was flashed successfully? Also, what BIOS version were you on prior to the update?

Might want to list the specs to your build like so:
CPU cooler:
including the age of the PSU, apart from it's make and model.