Ryzen, ASUS Prime B350 Plus Motherboard, no boot or beeps

Sep 3, 2018
1
0
10
0
Sadly this seems to be an often-repeated problem, and not many solutions.
(I know this will be long, but I'm trying to eliminate as many things as possible)

Ryzen 3 1200
ASUS Prime B350 Plus motherboard
Corsair CS650M PSU
XFX Radeon R7 360 2GB Video card
ADATA XPG Z1 8GB RAM
Corsair Carbide 100R Case

No storage connected temporarily, for testing.
Speaker from older system plugged into front panel speaker connector on M/B
PCI POST Test diagnostic card plugged into PCI slot

8-Pin EATX 12v plug well seated, 24 pin ATX power plug well seated, 6 pin PCI-E power plug seated on video card.

Monitor set to HDMI, plugged into the video card HDMI connector.

At power-up, case fans spin, CPU fan spins, motherboard decorative LEDs light, POST Test diagnostic card indicates all voltages present and CLK signal present on bus.
(This motherboard has no diagnostic LEDs on it.)

(Just to be clear, I first tried booting with everything plugged in normally including SSD, optical drive and hard drive. AFTER getting no response that way I removed the storage both SATA and power connections and then plugged in the POST test diagnostic card, so that wasn't involved in causing the first failure.)

No signal on video card, no beeps from speaker, no activity readout on diagnostic card (Display shows default - - - - on 4 digit display).
Diagnostic card indicates RST pulse when reset button on the case if pressed.

Having read about Ryzen CPUs taking a long time to boot on first bootup, I waited approximately 12 minutes, nothing.

Checked the PSU with a PSU tester, all voltages indicated present.
Reseated the modular plugs on the PSU.
Reseated the PSU connectors on the M/B and Video Card.

Suspecting a short to the case, I measured all voltages at the 24 pin connector (with the connector plugged into the motherboard as normal, using a probe on the rear of the connector), all are present.

Removed the video card, no change.

Removed the RAM from socket B2 (leaving a single module in socket A2), no change.
Removed the other RAM module, no change. Suspiciously, there are no diagnostic beeps from the speaker indicating no RAM is present.

All this time, the POST test diagnostic card shows NO activity on the bus.

Removed the CPU and inspected the pins, none bent.

Considering the indications of activity from the motherboard (responds to Power Button, Reset button, CLK signal present and both PSU and fans power up), I suspected a DOA CPU.

I RMA'd the CPU with AMD and while waiting for a return I noticed Newegg had the Ryzen 5 1500X CPU on sale so I bought one of those.
And of course, exactly the same thing is happening with the new CPU.

The RAM is not on the ASUS compatibility list as far as I can tell. However, even with no RAM installed, there's still no indication anything is happening when powered up, and no beeps.

It's puzzling there's no activity on the PCI bus (as displayed by the POST test diagnostic card) and no beeps from the speaker. Right now I'd be happy to get beeping complaining about no RAM.

As far as BIOS versions, this M/B should have a legit Ryzen BIOS already, and in any case there's nothing that can be done about that since it doesn't boot anyway.

At this point I'm stuck thinking it's a DOA motherboard, but I'd really like to be sure before disassembling everything and sending it back.

I'm hoping someone may know something about this M/B or Ryzens and can suggest a possible solution or see something I've missed.

Thanks!


UPDATE- Tried substituting a new Corsair 430 PSU just to check, no change... no boot.
Tried an old VGA PCIE card just to cover the bases, no change... no boot.



 
Feb 10, 2019
3
0
10
0


I know this is a bit of an older post but Check out this Link :
https://www.amd.com/en/support/kb/faq/pa-100

I had run into a similar problem, AMD is now sending out " boot kits" consisting of an inexpensive A series CPU (and heat sink) to allow us to update the bios to support our Ryzen CPU's Free of charge! You just need to send the Processor back within 10 Days, they provide a pre-paid return package. so it does not cost you a dime.
 

ASK THE COMMUNITY