Sabertooth 990fx issues


Dec 1, 2011
My asus sabertooth 990fx keeps resetting my settings every time i shut off my pc saying there is a ram issue and it was lowered to 1333mhz i have these ram sticks they are on the qualified vendors list. Ran memtest for 8 hours no issues with memory. I ran 1 stick in each slot and did the same for all my ram sticks no slots were faulty no ram sticks did not boot. I have tried everything from saving my profiles but nothing works. Even if i keep it at 1333mhz it keeps telling me that memok check passed and i need to hit f1 to save the setting in bios. does this has anything to do with cmos? do i need to reset? should i run only 8gb ram vs 16gb. Am i just unlucky and need to do a RMA on my stuff and do a new setup?

my system:

MB: ASUS Sabertooth 990FX AM3+ (bios version 0901) [...] 6813131736

CPU: AMD FX-8120 3.1ghz [...] 6819103961

RAM: CORSAIR Vengeance 16GB (4 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (currently running at 1333mhz)

PSU: PC Power and Cooling Silencer 760W High Performance 80PLUS Silver SLI CrossFire ready Power Supply

GPU: XFX Radeon 5850 BE

HD: seagate 700gb <-- don't know all the specs had it for over 3 years now

OS: Windows 7 professional sp1


Jun 9, 2010
I have 16G in my asus sabertooth 990fx and not had any issues with RAM.

My memory is Kingston 1600.

What version of BIOS are you on. I have updated my BIOS to 0901 and have had a few issues which were introduced by this BIOS.

Since then I have put the CLR CMOS jumper onto a switch so I can Clear BIOS easily.

The system time was lost a couple of times I did changes in the BIOS, not a big deal since W7 updates the time via internet.

Main issue is the REALTEK Chip has stopped sensing two of the ouputs (SUBWOOFER and Side speakers) orange and grey audio connectors.
This was working on the original BIOS (0702 I think it was).

Have had a million emails to ASUS tech support but they will not acknowledge the problem. I am not keen to go back to an old BIOS.

some stuff re my rig here

:pt1cable: Frank :pt1cable: