Saint's Row The Third Lag

yaweeeeeeee

Honorable
Oct 20, 2012
15
0
10,510
Specs:
Windows 7 Home Premium 64-bit
AMD FX(tm)-4100 Quad-Core Processor (4 CPUs), ~3.6GHz
Memory: 8192MB RAM
Available OS Memory: 8190MB RAM
Page File: 2545MB used, 13833MB available
DirectX Version: DirectX 11
NVIDIA GeForce GTX 650
Display Memory: 4045 MB
Dedicated Memory: 973 MB
Shared Memory: 3071 MB

Saying that, that being said, and having said that, why is Saint's Row the Third lagging so heavily?
Maybe 15-20 FPS
Much appreciated in advance!
 
Solution
You updated to the latest BIOS revision, correct?

Okay, there is another possible workaround for this. The problem is that the Steam DRM for this particular game and a few other titles does not agree with the FX CPUs for some reason. Go here and download and run the program at the start of the thread. It is an unofficial fix that was used to get the game running properly before BIOS updates were available for the AM3+ motherboards. Hopefully that will fix your problem.
I think you'll need to update your motherboard's BIOS. Saint's Row III has some issues with AMD's FX CPUs under some older BIOS revisions. Go to the motherboard manufacturer's website to search for the appropriate BIOS file for your board, and instructions on how to update it. Also make sure the game is patched to the latest version.
 

yaweeeeeeee

Honorable
Oct 20, 2012
15
0
10,510


I tried to update my BIOS to the latest version, but the installer doesn't like my 64 bit. What should I do?
 
If the Windows installer won't work, you'll have to do it in the DOS environment from a flash drive that is formatted with the FAT32 filesystem. Then you either use the command line to do it, or use the BIOS flashing utility that most modern motherboards will have within the BIOS. Refer to your motherboard's manual for detailed instructions on how to do it.

Follow the instructions to the letter, and make sure you have the right file for your specific motherboard model. A failed BIOS flash can brick your motherboard.
 

yaweeeeeeee

Honorable
Oct 20, 2012
15
0
10,510
Well, I went to the Gigabyte website, downloaded the latest BIOS for my GA-M68MT-S2, went into my BIOS settings at startup, flashed it, and the process completed successfully. I started Saint's Row the Third, but absolutely no change.
I had my doubts. The computer is only 2 weeks out of the box.
 
You updated to the latest BIOS revision, correct?

Okay, there is another possible workaround for this. The problem is that the Steam DRM for this particular game and a few other titles does not agree with the FX CPUs for some reason. Go here and download and run the program at the start of the thread. It is an unofficial fix that was used to get the game running properly before BIOS updates were available for the AM3+ motherboards. Hopefully that will fix your problem.
 
Solution

yaweeeeeeee

Honorable
Oct 20, 2012
15
0
10,510
I suspected I already had the latest BIOS revision. I updated it anyway. The process was successfully completed.

Ok I'm going to try this Orochi-CEG program and I'll let you know how it goes after work tomorrow.

EDIT: 2 MINS LATER: I couldn't resist and I started it up. 60 FPS! Now I just need to find an effective (permanent) revision for the BIOS!
 

yaweeeeeeee

Honorable
Oct 20, 2012
15
0
10,510


In my experience, to kill the lag, you simply run a program which corrects the problem before you want to run certain games. BIOS update is not neccesary. The program is called Orochi-CEG. Fixed all of my problems. Not even an inconvenience anymore. Just put shortcuts to all the programs that need it and Orochi-CEG in the same file.

Download HERE.
http://www.mediafire.com/?unuohgu8m7oji56