Question SAMBA . CONF doesnt, please help

Feb 25, 2019
6
0
10
0
Ok, its been Years since I tried SAMBA and its good to know that as easy as the raspi is, im not any better at getting it running here than I am on mandriva or RH or PCLOS or.....
I even followed a step by step and its not working. Probably because no step by step shows the use of an external USB hard drive. But thats what I have. Seagate 3GN USB external HD.

Heres what sudo DF shows:
/dev/sda2 3906885628 2842494236 1064391392 73% /media/Seagate Backup Plus

now if you could PLEASE just tell me what goes in smb.conf I would be forever greatful. I mean I have tried ever combination I can think of and nothing woirks. my SMB.CONF ony has a few lines in it, so it shouldnt be a big deal. but somehow I keep screwing it up.

any and all help appreciated.

thanks

j

in case it help this is whats in my smb.conf now

[global]
netbios name = LrVolumio
server string = Audiophile Music Player
workgroup = WORKGROUP
security = user
map to guest = Bad User
encrypt passwords = yes
wins support = yes
local master = no
preferred master = no
os level = 30



[USB]
comment = LrVolumio USB Music Folder
path = /mnt/USB
path = /media/"Seagate Backup Plus Drive"/MUSIC

read only = no
guest ok = yes



Im sure its in the lines under USB sectoipn, just cant figure out where....
 
  1. YOu have two "path = " lines in your config. It's unclear which one, if ever, will be taken
  2. Try first to share a simple folder like /home/<yourname>. I suppose the spaces in the mount point play a role in your "success".
And last but not least - you did not say what is your problem, nor what system and Samba logs say about it.
 

davesnothere

Commendable
Aug 6, 2016
39
2
1,565
6
using what you provided, having security=user, which is users created on the rasp-pi. It could be set up this way:


[global]
netbios name = LrVolumio
server string = Audiophile Music Player
workgroup = WORKGROUP
wins support = yes
local master = yes
preferred master = auto
valid users = pi

[USB]
comment = LrVolumio USB Music Folder
path =/media/Seagate Backup Plus/MUSIC
browseable=Yes
writeable=Yes
only guest=no
create mask=0777
directory mask=0777
public=no

you must have the package samba-common-bin installed for the next step
(sudo apt-get install samba-common-bin )


add your user (using the generic username: pi in the example)

smbpasswd -a pi

then fininsh by setting up share ownership:

sudo chown nobody:nogroup /media/Seagate Backup Plus/MUSIC
 

mindwave

Prominent
BANNED
Apr 25, 2018
4
0
510
0
Dave, Thanks I'll take a look when I get home and see how that works.

Alabal: I was SO Frustrated, that by the time I got here to post I couldn't see straight, the Raspi.org forum is about the most Unfriendly SW I have ever seen. But youre right I left a lot out lets see if I can fill in:

I have a RASPI 3B+ setup as a VOLUMIO, works well, except that I'm a data junky and everytime I get 10-20GB of new music I want to install I hate having to sneaker net it downstairs, SO: the 3B+ running Raspbian with a Seagate 4TB External HD hooked up via USB.

It reads on the RASPI with no issues, but I can not get it seen on my network to save my life. I know its there, because I SSH from all over the house.

Honestly I haven't looked at the SAMBA logs yet, but as SIMPLE as samba is for 99% of the planet its that MUCH worse for me. I cant tell you how many different ways I have tried to configure samba over the years. Ive used toolsets that ":automate the WHOLE world" but cant see MY drives....

YEARS ago I found a step by step that worked EVERY single time. Than the Hurricaines came through (I live in FL) and one flooded garage later and all my notes were gone.......

never been able to get it to work since,,,,,,,

netware, I could do in my SLEEP

samba, just drives me nuts

thanks for all the suggestions, the path USB is silly, Ill kill that too
 
Feb 25, 2019
6
0
10
0
OK, so Im still working my way through what should NOT be an issue , I know but it is, heres what has happened:
I remember from working on my desktop that all my usb drives eventually show up in /media/XXXX so I cd'd over to media did a sudo ls and low and behold:
/media/Seagate Backup Plus Drive

so i tried copying some files to it, PERMISSIONS error, tried creating a directory on it, PERMISSIONS error

so I did what I thought SHOULD fix that (admins and linux purists dont look) did a :

chown 777 Seagate Backup Plus Drive

so I can manually do things with it, but what cant I do?

fdiak -l shows NOTHING related to that drive
sudo df ahows NOTHING related to that drive

im trying everything and anythingh someone suggests that makes sense, so please if youve had and resolved anything like this it would be appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS