Question Same motherboard bought twice, neither posts

Jul 20, 2019
10
0
10
0
Hello

I've never posted on here, but I'm desperate to get this PC to work before I go to college. I bought a bunch of parts to turn my rig into a mini-ITX rig so that's it's easier to handle. I didn't want to spend too much money, so I just bought a new case, motherboard, CPU cooler, and PSU. Specs are as follows:

CPU: i5-7600k
Motherboard: gigabyte ga-b250N Phoenix wifi
Cooler: Noctua NH-L9x65
Case: cooler master elite 130
GPU: gigabyte gtx 1060 6gb
SSD: ADATA 120GB
HDD: 2x wd green 2tb 5400rpm
PSU: Corsair cx 650w
RAM: ADATA xpg 2133 MHz 2x 8gb

I bought the first motherboard, didn't work, wouldn't post. I returned it and got a new one, didn't work again. Everything should work and is supported with the motherboard, and I've vetted that every other component works using the old motherboard. I've reset the cmos, reseated the battery on the Mobo, tried with one stick of ram, tried out different slots, nothing works.

Also if anyone has a mini itx motherboard that works with 7th gen Intel CPUs, lmk, I'll buy it.

Help, this PC is going to be the end of me.
 

COLGeek

Cybernaut
Moderator
Okay, now I am un-confused. This is why this wasn't making sense to me. Give me a minute to ponder this.

After resetting the BIOS and with only the CPU and memory installed (no storage devices attached, nothing plugged into any slots or ports other than the display, keyboard, mouse), does anything change in behavior?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts