Question Samsung 32' 4k Monitor Suddenly Not Working?

pauly01

Distinguished
Oct 3, 2013
186
0
18,680
0
I have a samsung u32j590 monitor which is a 32' 4k monitor that I bought last year. It had worked good with no issues.



Now today when I power it on, it shows in the top left corner Displayport as usual. But its suppose to go to the main screen. My dell xps 15 9550 laptop is connected to 2 monitors... this one and an older 24' monitor. This samsung 32' monitor is connected with one cable to my laptop... and the other 24' monitor is connected with another cable to my laptop. This 32' is connected to my laptop with a display port to the back of the monitor. The other 24' monitor i connect with an hdmi to hdmi cable.



So the monitor keeps turning off... then turning back on and keep displaying displayport in top left corner. How do i fix this issue? When you click on the power button, I do see the square box in the bottom corner where you can click on menu. There is also the option to go from displayport to hdmi 1 and hdmi 2 but of course its displayport.



Does anyone know how to fix this issue? My other 24' monitor does turn on but this one doesn't?


Thanks.
 

pauly01

Distinguished
Oct 3, 2013
186
0
18,680
0
It also doesn't seem to detect this monitor. Does anyone have any advice on this? I unplugged the cables from monitor and plug it back in... same issue. My laptop is an old
dell xps 15 9550.



Basically there is a blue light flashing while screen is black. Y ou click on power button and it shows square box in bottom right corner with options of menu, source, power on and return. I clicked power off. Then press power button and its back to same menu.
 

ASK THE COMMUNITY

TRENDING THREADS