Samsung 840 EVO Firmware EXT0BB6Q: No more RAPID mode?

godhand136

Distinguished
Feb 1, 2012
8
0
18,510
0
I just updated my Samsung 840 EVO to firmware EXT0BB6Q and was immediately greeted with problems. I did it using magician, which had me disable Rapid mode to flash, and then it began its process and turned off. I turned my PC back on, and it would no longer flash. I did this a couple times to no avail and then I was greeted with a " Previous boot failed do you want to start without quick boot (which I have had enabled in BIOS). I said sure why not, and viola it worked after doing a start-up repair (actually after trying it 2 times with it enabled). So now I'm in magician, and I have the updated firmware number, the new Data security options, and actually much better IOPS (with marginally worse Read/Write). I go to RAPID Mode and there is no disk for me to select in the drop down and enable RAPID mode. Has it been disabled? Or is it always on? Anyone have similar problems? Figured I'd ask you guys, the best forum on the web.
 

Since1979

Honorable
Dec 13, 2013
4
0
10,520
1


I am having the same problem as the original post states. Same experience with the new Firmware update. Magician said "you must disable Rapid Mode to update Firmware", so I clicked disable Rapid Mode, came up with "disable Rapid Mode Failure" error. Read somewhere to uninstall Magician, reboot, install latest version of Magician, update Firmware. I did all that, everything is working, however Rapid Mode Screen says "Not Supported" and my system is well above the requirements for Rapid Mode.

Now, all that being said, I did some of my own searching around my system/files and what I've found is,,, Rapid Mode was never removed when I uninstalled Magician. I still have Folders for Rapid, one is located in My Documents/Samsung/Rapid and the other is located in Windows/System32/Rapid. When I open Task Manager and click "show processes from all users", SamsungRapidSvc is in fact up and running, this is even though Samsung Magician says Rapid Mode is "not supported".

I've been building Computers since, as my member name says, 1979, but software or programs is not my specialty. So this is the best I could find blindly looking through files and folders on my computer to find out why the Rapid Mode is not working properly since the EXT0BB6Q Firmware update.

To the best of my knowledge, Rapid mode was never uninstalled with Magician when I uninstalled it in the first place, whether or not it has something to do with Firmware update EXT0BB6Q or not is beyond me. I played around with the folders and removed the files from each of the two locations I found (listed above) and put them into a newly created folder so not to lose them. Rebooted and re-ran the Benchmark test. My scores went back down too 58769 / 56294 Random Read/Write and 548 / 500 Seq Read/Write. Put the files back to where I found them, rebooted and then re-ran the Benchmark again, and again I was back too 63706 / 81551 Random Read/Write and 1040 / 968 Seq Read/Write.

Briefly my system is:

i7-3820 @ 3.6 GHz
Gigabyte Assassin2 intel LGA 2011 X79 chipset Motherboard
32 GB gskill 1866 ram
Samsung 840 EVO 1TB SSD
Gigabyte GTX 680 GPU
Windows 7 64bit

I don't overclock so everything is running at factory settings.

So even though Samsung Magician is saying "Not Supported" I am pretty sure I'm still using Rapid Mode.

Hope this helps someone else, and Hopefully Samsung will fix whatever is causing these issues with the Firmware / Magician / Rapid Mode problems :)
 

godhand136

Distinguished
Feb 1, 2012
8
0
18,510
0


Oh sorry, forgot to mention that. It says: "Status Not supported". The little table at the bottom says I meet all requirements as well. This is a brand new drive with a clean install as of 2 days ago. So that is why I was wondering if they just removed it or something. Wanted to ask Samsung support, but they're closed for the night here.
 

godhand136

Distinguished
Feb 1, 2012
8
0
18,510
0


Just tried that. Still same problem. I'm thinking about flashing back to the old firmware and then maybe trying the new again? I'm not so sure how I feel about that after I thought I bricked the drive the first time. Maybe RAPID mode is supposed to not show up? Under my processes I noticed Samsung RAPID Mode Service running and there does seem to be RAM being used that is unaccounted for in task manager....
 

godhand136

Distinguished
Feb 1, 2012
8
0
18,510
0

Hmmm the history on the drive doesn't show up anymore. The read/writes are crazy, leading me to believe they aren't correct perhaps (or RAPID, really is on). I ran the test today R/W is 1119/1019 MB/s which is pretty much double the advertised speeds. IOPS tend to be varying wildly from 75k- 91k with the Random Read tending to hit that lower end of that spectrum. Still amazing. I don't want to look a gift horse in the mouth, but the drive did have some problems flashing. Anyone else have any similar experience with the drive, and/or its software when updating?
 

Since1979

Honorable
Dec 13, 2013
4
0
10,520
1


I am having the same problem as the original post states. Same experience with the new Firmware update. Magician said "you must disable Rapid Mode to update Firmware", so I clicked disable Rapid Mode, came up with "disable Rapid Mode Failure" error. Read somewhere to uninstall Magician, reboot, install latest version of Magician, update Firmware. I did all that, everything is working, however Rapid Mode Screen says "Not Supported" and my system is well above the requirements for Rapid Mode.

Now, all that being said, I did some of my own searching around my system/files and what I've found is,,, Rapid Mode was never removed when I uninstalled Magician. I still have Folders for Rapid, one is located in My Documents/Samsung/Rapid and the other is located in Windows/System32/Rapid. When I open Task Manager and click "show processes from all users", SamsungRapidSvc is in fact up and running, this is even though Samsung Magician says Rapid Mode is "not supported".

I've been building Computers since, as my member name says, 1979, but software or programs is not my specialty. So this is the best I could find blindly looking through files and folders on my computer to find out why the Rapid Mode is not working properly since the EXT0BB6Q Firmware update.

To the best of my knowledge, Rapid mode was never uninstalled with Magician when I uninstalled it in the first place, whether or not it has something to do with Firmware update EXT0BB6Q or not is beyond me. I played around with the folders and removed the files from each of the two locations I found (listed above) and put them into a newly created folder so not to lose them. Rebooted and re-ran the Benchmark test. My scores went back down too 58769 / 56294 Random Read/Write and 548 / 500 Seq Read/Write. Put the files back to where I found them, rebooted and then re-ran the Benchmark again, and again I was back too 63706 / 81551 Random Read/Write and 1040 / 968 Seq Read/Write.

Briefly my system is:

i7-3820 @ 3.6 GHz
Gigabyte Assassin2 intel LGA 2011 X79 chipset Motherboard
32 GB gskill 1866 ram
Samsung 840 EVO 1TB SSD
Gigabyte GTX 680 GPU
Windows 7 64bit

I don't overclock so everything is running at factory settings.

So even though Samsung Magician is saying "Not Supported" I am pretty sure I'm still using Rapid Mode.

Hope this helps someone else, and Hopefully Samsung will fix whatever is causing these issues with the Firmware / Magician / Rapid Mode problems :)
 

ebalong

Distinguished
Sep 11, 2011
422
0
18,790
4
Hmmmm.....reading this thread makes me wonder if I should just stick with the EXT0BB0Q version that came installed on my brand new 840 Evo 500GB. I ran Magician today and it prompted me to update the firmware.....bear in mind that I am on Win 7 Pro. I read about the newest firmware, and it seems like the only benefit over the previous version is that it enables some encryption compatibility with the Win 8 encryption process.

Is this all there is to the new firmware? If I don't care about that stuff, can I skip this update? I almost hit the update button, but after reading this....I am not sure now.
 

Andasa

Honorable
Dec 16, 2013
3
0
10,510
0

Same for me. I had the exact same update scenario. No drive in the combobox on the RAPID tab, but RAPID seems to be still running.
 

Palorim12

Honorable
May 3, 2013
706
0
11,360
108


all the FW update does is:
- Support advanced data security features(TCG/Opal and IEEE 1667)
- Optimizing TurboWrite algorithm
 

Andasa

Honorable
Dec 16, 2013
3
0
10,510
0
I have tried all combinations of uninstall and reinstall I can think of but nothing seems to be able to bring the disk back to the RAPID Mode tab in Magician. I have noted a number of things:

  • ■ The RAPID driver and service do NOT uninstall or even disable when I uninstall Magician.

    ■ Neither Magician 4.2 nor 4.3 will show my disk anymore on the RAPID tab. I get "Not Supported" or "Retrieving information" as status.

    ■ RAPID itself seems to be totally unaffected by Magician. It keeps running no matter what I do with Magician.

    ■ I can disable RAPID manually by disabling the service SamsungRapidSvc, but I have not found a way to uninstall or reinstall it.

    ■ The Magician log file has an entry that says "RAPID Is in Enabled State" but shortly after there is another entry that says "SOMETHING WRONG... Not supposed to come here"
 

Since1979

Honorable
Dec 13, 2013
4
0
10,520
1
Everything you list Andasa is exactly the same for mine and probably many others. Going by the benchmark readings using the benchmark feature within Magician, I believe we are still in RAPID Mode. The only way I found to disable RAPID Mode completely is to do what I listed on my earlier post. Two locations I found are in My Documents/Samsung/Rapid and the other is located in Windows/System32/Rapid. If you create a folder in "Documents" for example, name it "Save4Now" or something you'll remember easy enough, put the 3 files (if I remember right) in it and then re-boot, you will be out of RAPID Mode and the "SamsungRapidSvc" service will no longer be up and running. Run a quick benchmark in Magician and you'll see you are out of RAPID Mode. Then you can put the files back into their proper folders and re-boot again and RAPID will once again be up and running :)

After doing all the checking around that you've probably also done, I finally decided to wait for a Samsung Magician Update (if it comes out) to see if it addresses the RAPID Mode issues. If it doesn't then I'll go with the impression that even though Magician says "Not Supported" under the RAPID Tab, I'm pretty confident it's working :pt1cable:

The only thing that may fix it completely is a complete wipe of the EVO SSD and re-install from scratch like it was the first day I received it, but since everything else is running great, I just can't justify going through that because of a Magician Software glitch.

If I find anything out or if Samsung addresses the issue with an update, I'll be sure to come back to this thread and post it, just in case anyone can use the information.
 

oopswassup

Honorable
Jan 20, 2014
2
0
10,510
0


Interesting reading. I switched on my PC running Windows 7 on a samsung 840 EVO 250 Gb and got the BSOD !
% hours so far and no success. THe BSOD shows 0x0000007E SamsungRapidDiskFltr.sys
 

oopswassup

Honorable
Jan 20, 2014
2
0
10,510
0
I followed Since1979's advice and removed SamsungRapidDiskFiltr.inf and SamsungRapidSvc.exe, SamsungRapidDiskFltr.cat, and SamsungRapidDiskFltr.sys and placed them on a USB key. After 6 hours with the BSOD my computer is up and running without these files.
I hope samsung comes up with an update because this is a very serious issue. I work with my computers and 6 hours downtime is not good.
 

Since1979

Honorable
Dec 13, 2013
4
0
10,520
1


Good thing is, you're back up and running! Sounds like in your case, your Computer doesn't get along with RAPID Mode at all. But that's probably a whole new issue you probably don't want to get into after the downtime and since it is running fine without the RAPID Mode, until something is addressed by Samsung on the RAPID issues, I'd go with the old saying "if it isn't broke, don't fix it".

Bottom line, I added that little work-around to temporarily disable RAPID, but in your case I'm glad that it helped you getting back on-line. As long as it runs stable without, I'd leave it until something firm comes from Samsung on the issues.

Best of Luck :)
 

Since1979

Honorable
Dec 13, 2013
4
0
10,520
1
As promised, when I figured something out, I wanted to come back to this thread to hopefully help others.

I recently bought a Samsung 840 EVO 750 GB SSD for my other computer. I carefully went through the steps. I first Cloned my original HDD to the EVO SSD. Once in Windows 7 64, I installed the Samsung Magician 4.3 Software. I then did the Firmware update to EXT0BB6Q. After the reboot, I then switched on RAPID Mode. Everything worked great!

I then did a comparison between the 2 computers. Here is what I found :

On the computer that was just upgraded to the 750 GB EVO I checked regedit, found nothing, checked Windows\System32\RAPID, and found nothing different there either. Then I looked at Program Files (x86)\Samsung and found the difference between the 2 computers.

In that folder was a sub folder named RAPID,,, imagine that! :love:
I double checked on the original EVO computer and under Program Files (x86)\Samsung I only had the sub folder named "Samsung Magician" there was no "RAPID" folder,,,

So I copied the folder to a USB drive and dropped a copy of it into my Program Files (x86)\Samsung, so I now had 2 sub folders "RAPID" and "Samsung Magician". I rebooted and then opened the Samsung Magician and RAPID was now working properly again. I have the Circle Icon next to the word RAPID on the Magician home page again. I clicked on it and there was my drive once again listed on the drop down list! I also read the notepad file or text file "RAPIDStatus" before rebooting and of course it had the information for the 750 GB EVO and this one is the 1 TB, but I went on the hopes it wouldn't raise a flag on that. I checked that file after the reboot and opening Magician and it updated that file to the 1 TB information and wiped all the 750 GB information out.

So in closing, it's all working again, I have RAPID mode showing in Magician, the drop down shows my Samsung EVO and the disable button is once again lit up should I want to try and disable RAPID Mode (which I don't :no:) !

I truly hope this helps anyone else who has been extensively trying to fix this issue. Since I did have to have it installed on another computer, I'm not sure if there is someway to get copies of the folder other than installing the EVO on another computer fresh and making a copy of the folder to a USB and then putting the EVO back into the original computer. That's a lot of writes and erases to the drive. But there must be a logical way to get it.

The Folder is named RAPID, there are 2 sub folders inside, 1 is "Cachefilter" and the other is "Tools" and then there are 2 note pad or text documents under those 2 sub folders called "OpenSourceAnnouncement" and "RAPIDStatus".
All total it's a 1.21 MB folder that you really need to once again get RAPID working in Magician 4.3 as it should!

Again I truly hope this helps a lot of folks out there,

Best of Luck :wahoo:
 

Thomas Brosinski

Reputable
Apr 26, 2014
1
0
4,510
0
Dude, if your benchmarks are as high as you say they are, stop, leave everything alone. You may not be see Rapid mode anymore but your b-marks are off the chart, so leave it alone and move on. I personally would love to have those benchmarks. I'm running Magician 4.3 on my EVO 250gb and my benchmarks are Seq read 628 / Seq write 564 both above the advertised 540/520 and I'm happy.
 

Federacion

Reputable
Sep 28, 2014
1
0
4,510
0


That's great! Where can we find those 2 documents so we can do the same?
 

JohnnyMash

Distinguished
Oct 30, 2006
81
0
18,630
0
My RAPID mode was disabled ( RAPID Mode is in inactive state - Disabled due to internal errors ) I could not enable RAPID Mode after trying many other fixes. The RAPID folder and its contents existed, and it was working fine when it was first installed. I solved it using these steps:

- Reinstall the latest Samsung Magician software.
- Reboot as necessary until you have RAPID Mode disabled in Magician.
- Go to C:\Program Files (x86)\Samsung\RAPID\CacheFilter (or wherever your SM install is located)
- Right click on the file "SamsungRapidFSFltr.inf" and choose Install. DO NOT choose to immediately reboot!
- Right click on the file "SamsungRapidDiskFltr.inf" and choose Install, and choose to reboot now.
- After reboot, check if RAPID mode is enabled, otherwise hit the Enable button and reboot again.

This worked for me.
 

feligato

Commendable
Sep 14, 2016
2
0
1,510
0


I don't have "SamsungRapidFSFltr.inf" in my installation of Magician

Im using Windows 10 and the performance is very poor
I alredy have optimized the OS via Magician software but cannot activate Rapid Mode, also the performance test doesnt work

 

Palorim12

Honorable
May 3, 2013
706
0
11,360
108


Since you're in Windows 10, do you have the most recent version of Magician installed?
 

feligato

Commendable
Sep 14, 2016
2
0
1,510
0


Yep, the last one

But, reading the magician documentation a came across a detail about the supported chipsets, in my case an AMD one. It says that you need to have the latest drivers (of course) and that was my case. But then I remembered that I have an HP Intel based notebook in my work, that was practically identical to the one I was trying to get this thing running. I swapped the disks, boot directly from the ssd in this Intel machine, updated the OS and drivers and when a I run magician to see the configuration I saw that Rapid was up and running with no problems

So I think maybe the amd drivers or hardware are not well tested or prepared for this Samsung disks
 

ASK THE COMMUNITY

TRENDING THREADS