Question Samsung 850 evo SSD dead?

Aug 26, 2019
2
0
10
0
Watch your Language
Hello folks,

My hair has been falling since saturday, my computer is being not able to detect my Samsung 850 evo 250gb since.
I can't remember if last time it was running i quited normally or through the power button.
I tried:
  • switching sata wires, all works fine.
  • clearing cmos and a bios firmware update but nothing. And a rainbow of BIOS combination setups.
  • about 10 power cycles (~>=60 min only power + 30 s without power + start process again) with 0 results.
When I run into the BIOS device is never detected except when I switch from sata AHCI mode to RAID mode. In that case if i run any linux based OS (didn't tried with windows) it detects the device but the "Boot device error" appears . If I execute any live utility the drive is detected at the device manager but I'm not able to mount it.

Also, in RAID mode, I tried with UBCD Hardware Detection Tool and I've discovered that my ssd have 3 partitions with negative cylindres and one of then marks as a 960Gb size (exact size like my 1TB hdd seagate drive), so extrange!!.

I can't remember if 3 years ago I make a misstake enabling raid mode or what happened but,

can someone tell me if my drive has any possible chance for returning back to life? it was too young.

My setup:
  • i5 660k
  • msi z170a pc mate
  • sata 1 - samsung 850 evo 250gb ssd
  • sata 4 - seagate 1 Tb hdd
  • 16 gb RAM 2133MHz
 
Last edited:
Aug 26, 2019
2
0
10
0
did you try to switch sata spot with HDD?
Sorry for the late response.

Yes, as I said at the begining.

Anyway, after trying all mentioned above + the next:
  • With a SATA to USB drive i tried to see partition tables with Samsung Magician, Crucial Storage Executive, MBRTool, MBRWork, UBCD, AOEMI Recovery Tool.
  • Activate SATA Hot plug at UEFI and then expecting windows or linux drive detection with zero results excepting a freeze in windows 10 :)
Last night i used chckdisk from AOEMI and observed all major of sectors were corrupted so i suppose my ssd is ready to be recycled in a new tool.

I've received a 2 new SSD but (M2. Crucial MX500 and SATA 3 Crucial BX480) and installed Windows 10 on the M.2.
I must say I was having problems detecting the new BX480 but it looks ok after some Crucial Storage Executive scans and SMART looks normal. Also perfomed a AOEMI checkdisk check and all it's ok.
 

ASK THE COMMUNITY

TRENDING THREADS