Question Samsung 860 EVO 1TB won't allow me to enable rapid mode .

Dec 14, 2018
4
1
15
0
Cloned my 850 evo 500G onto 860 EVO 1T using magician. New 860 EVO is bootable and is running well with several exceptions.
Magician states the rapid mode is not supported and the overprovision dialogue in magician not displayed.

The system runs ok but when running my 850 evo with rapid enabled it was faster. The 850 evo is no longer attached to the machine.

AHCI and TRIM are enabled. Any guidance about using magician or anything else to turn on overprovisioning or Rapid would be appreciated. I have dell 8300 with 16GB and intel i7-2600.

Thanks
 
Dec 14, 2018
4
1
15
0
I understand that the Rapid cache is illusory but other features of Magician don't work either, Over-provisioning is not presented to the user in magic. maybe I'm being picky but I would like all the magic features to work because when some work and some don't, I'm suspicious of all the results.
 
Dec 14, 2018
4
1
15
0
What is the specific version of Magician do you have? It may need an update.

My 1TB 860 EVO (Magician v 5.2.1) :
PROBLEM SOLVED! After I cloned my 500 GB 850 EVO to my new 860 1 TB EVO, I booted from the 860. System ran fine. Next I started Magician 5.1. In the past the firmware version was checked approximately weekly and I failed to update either firmware or magician because it was apparently unnecessary. This time when Magic looked at the new drive, several errors were encountered, unrecognized drive, not genuine and rapid mode, over-provisioning and secure erase were not listed on the bottom of the front page of Magician.
The update button was displayed and Magician updated to 5.3, The drive was reported as recognized and genuine but the rapid mode button was still missing as were Performance optimization, Over-provisioning and Secure Erase.
At this point I went back to the internet with no luck. My next step was to remove Data Migration and Magician from my system. I reinstalled both pieces of software from the Samsung website.. At last all the usual options and the Rapid mode button reappeared. Earlier , rapid mode was removed from the 850 so no collision there. Followed the rapid mode instructions and now all is well although my second drive, the 500 GB 850 EVO won't run in sata 6, but only runs sata 3 on this system. I don't need the 850 and I'm giving it to my cousins and am not going to fight the sata 3 mode issue.

Thanks for the suggestion about the Magician version. I suggest removing the old one first and reinstalling Magician from the Samsung website..

P.S. Also removed my 1 TB HDD. I had been keeping the files generated by a large project on it. Now the files are on my main drive the 860 EVO. The entire machine is quieter, runs
cooler and boots quicker thanks to the departure of the 1 TB HDD.

Glen
 
Reactions: Banned by Net

ASK THE COMMUNITY

TRENDING THREADS