[SOLVED] Samsung 860 QVO no longer showing info in Samsung Magician ?

Feb 7, 2021
7
0
10
0
I recently updated Samsung Magician to 7.0.0 and I noticed my Samsung SSD 970 EVO and my two Samsung 860 QVO SSDs no longer display health and temperature information, and I could no longer use any of the utilities.

I fixed my 970 EVO by reinstalling the Samsung NVMe driver for it, and now it shows all the information correctly and I can use the tools.

However, both my 860 QVOs are still showing "'N/A' is represented in 'Drive Health'.
On the Samsung Help page, it states this error is due to a network connection being required to authenticate they are authentic Samsung SSDs. The confusing thing is that these have worked correctly on Samsung Magician before, and they are legitimate (purchased through Samsung). I also don't have anything blocking the connection to their authentication service, which they mention in the article.

Looking online, most threads asking this similar question state that the issue is fixed by setting the SATA mode in the BIOS to AHCI from RAID. I have never set this setting to RAID, and when I checked it, it was using AHCI.

Digging further, I noticed in Device Manager that the two drives appear as "Samsung SSD 860 SCSI Disk Device". The 970 EVO also appeared this way, until I installed the NVMe driver again. The issue here is, I uninstalled both 860 QVO devices, but there's no download on Samsung for drivers for these devices because they're plug-and-play SSDs. So rebooting just made them appear that way again.

I've used both these drives for nearly a year now, and whenever I have run diagnostics to check their health, there have been no issues.

I've fully updated Windows (10), and I have also updated my BIOS to the latest version, to no avail. My motherboard is an ASUS Crosshair VIII Hero.
I switched the SATA ports that the drives were in as well, and this made no difference.

I also booted up HWInfo to check if SMART information was being displayed on these two SSDs, and they were not. SMART information was showing for my 970 EVO.

Any help is massively appreciated.
 

Lutfij

Titan
Moderator
BIOS version for said motherboard? I'd also ask you to check and see what OS version you're on. Following that, try and reinstall your chipset driver in an elevated command, i.e, Right click installer>Run as Administrator.
 
Feb 7, 2021
7
0
10
0
Hi, thank you for the response.
I am running Windows 10 Version 20H2 (KB5005611) and my BIOS version is 3801.

By Chipset driver, are you talking about my CPU chipset or a different one? Edit: I've updated my CPU chipset with the Ryzen utility and unfortunately that has not worked.

Many thanks,
 
Last edited:
Feb 7, 2021
7
0
10
0
I contacted Samsung memory support and they replied with a list of fixes, two being:

  • Make sure that only Microsoft SATA drivers are installed.
  • Please verify and if necessary, update the SATA AHCI controllers via Device Manager
I've discovered that IDE ATA/ATAPI Controllers were nonexistent on Device Manager on my computer.
I've tried manually installing the AMD SATA Controller and also the Standard SATA AHCI Controller, however both report:

"
This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

A device which does not exist was specified.
"

Looking online for hours, the only fixes I have seen is setting the SATA mode to AHCI (mine has always been AHCI, I have never touched it) or a full reinstall of Windows - which I am skeptical about doing.

Edit: On device manager and going View -> Hidden Devices there are two Standard SATA AHCI Controllers hidden, and they are hidden for Code 45 (currently not connected to the computer)
 
Last edited:
Feb 7, 2021
7
0
10
0
So after some time I finally discovered what was causing this.

I was watching a video on youtube and they mentioned AMD StoreMi briefly and I remembered when I updated my chipset, it also installed StoreMI on my system. I did not use this software, but I tried uninstalling it anyways. Once I did that, my SSDs were detected correctly again!
 

ASK THE COMMUNITY

TRENDING THREADS