Samsung 960 evo not detected in bios

Status
Not open for further replies.

kwantuM

Commendable
Dec 13, 2016
4
0
1,510
0
I'm having trouble installing my new Samsung 960 evo SSD.

My Windows is installed on my data HDD right now, and I want to move the installation to the SSD using Samsungs Data Migration tool.
The HDD was connected to the first SATA connector.

I plugged the SSD into the m.2 slot on my Asus z170 Pro Gaming mobo. Result: nothing. The drive is not visible in the BIOS nor in Windows.
I tried setting the "M.2 and SATA Express SATA Mode Configuration [SATA Express]" from [Auto] to [M.2]. This resulted in 0 drives being detected.

After moving the HDD to SATA slot 3, the HDD was being detected again. Still no SSD though.

I can't install the Samsung NVMe driver, as it says no drives are detected. The Samsung Data Migration tool does not detect anything either.
My bios mode is UEFI.

Can anyone help me out?
 

ivanmalley

Commendable
Dec 21, 2016
1
0
1,520
1
I had the same problem but sorted it as follows, make sure you have the latest BIOS installed - mine is now on 2003 link here http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/Z170-PRO-GAMING/Z170-PRO-GAMING-ASUS-2003.zip


1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don't think this would work with previous versions.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode.

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install.

Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.

I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.

The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.

Hope this works for you.

Ivan
 

DR_Luke

Respectable
Dec 1, 2016
363
0
2,160
106
If the data is valuable to you, you will probably need the assistance of a professional data recovery lab. But, this model of SSD is quite new and not widely supported, yet, by most labs.

Otherwise, just get it replaced under warranty.
 

kwantuM

Commendable
Dec 13, 2016
4
0
1,510
0

I'm having trouble installing the SSD, why do you think I need data recovery?
 

Barty1884

Titan
Moderator
Sounds like your M.2 slot is in SATA mode - as SATA port #1 is disabled when your M.2 is operating in SATA mode. With the 960 EVO being nVME/PCIe, that would ressult in 0 drives being detected.

Now, it should auto-detect a PCIe M.2 and not run in SATA mode, so I'm not sure what the answer is - perhaps here's another setting to manually confirm PCIe mode on the M.2 in your BIOS? Or perhaps you have something installed in the corresponding PCIe slot the M.2 shares bandwidth with (if any, can't find anything to confirm).
 

DR_Luke

Respectable
Dec 1, 2016
363
0
2,160
106

Doh! I completely mis-read the OP. I was reading it like you were using it for a while and it suddenly is no longer accessible. Sorry for the confusion.
 

kwantuM

Commendable
Dec 13, 2016
4
0
1,510
0

I can't find any setting for this in the BIOS.. And I don't know if the M.2 shared bandwidth with anything. I only have a graphics card installed, that shouldn't be a problem, right?
 

The Paladin

Illustrious
Ambassador
1. The manual to your motherboard is located at https://www.manualslib.com/manual/972232/Asus-Z170-Pro-Gaming.html
1a. Samsung 960 EVO driver is located at http://www.samsung.com/semiconductor/minisite/ssd/product/consumer/960evo.html
2. congrats on the Samsung 960 EVO, you mention M.2 slot so I will assume your using Model MZ-V6E500 (500 GB) ?
3. Your board supports only as per spec page (page Vii) : 1 x M.2 Socket 3 with M Key, type 2242/2260/2280/22110 storage devices, support (both SATA & PCIE 3.0 x4 mode)*
with a note following: * When the M.2 Socket 3 is operating in SATA mode, SATA port 1 will be disabled
4. On page 35 (1-25) they indicate The SATAEXPRESS connector can support one SATA Express device or two SATA
devices

Now have you tried putting the EVO drive into the M.2 (sata) and putting HDD in SATA port 2, change bios to boot on your HDD first, boot windows, install driver, see if the windows "Computer Management" looking at "Disk Management" if the drive show up (probably has no partition)?
 

kwantuM

Commendable
Dec 13, 2016
4
0
1,510
0


1a. The driver won't install as I said in my main post : "No drives are detected".
2. I have the 250GB version.

The EVO drive is installed in the M.2 slot, HDD in SATA port 3.

Inside the BIOS, there is a list of drives, but that does not contain the M.2 slot. I am unable to find ANYTHING related to the M.2 slot, only SATA 1 - 6.
With the HDD in SATA slot 3, my computer will boot normally (Windows is on the HDD). The SSD is not detected anywhere, does not show up as a bootable device nor in disk management.

EDIT: The M.2 slot should be operating in PCIe mode, not SATA. I don't understand why it won't.
 

The Paladin

Illustrious
Ambassador
EDIT: The M.2 slot should be operating in PCIe mode, not SATA. I don't understand why it won't.
I was going to tell you that drive is PCIE 3.0 x4 Compatible not SATA
so enter bios, Goto advanced menu, SATA settings, and change it there under page 72 if the manual I listed earlier of your motherboard and I quote
SATA Device Type [Hard Disk Drive] Allow you to identify the installed SATA device type. Configuration options: [Hard Disk Drive] [Solid State Drive]
I bet you need to change that to SSD setting for it to recognize it

then set the M2 setting next
Typology [Unknown] This item allows you to identify the SATA topology. Configuration options: [Unknown] [M2] [Direct Connect] [ISATA] [Flex
 

ahappydude

Commendable
Dec 18, 2016
8
0
1,510
0
I just built my computer today with the same result "ssd not detected". I also have the 960 evo 250gb and cant install it on my Asrock x99 i7 gaming motherboard.
 

ivanmalley

Commendable
Dec 21, 2016
1
0
1,520
1
I had the same problem but sorted it as follows, make sure you have the latest BIOS installed - mine is now on 2003 link here http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/Z170-PRO-GAMING/Z170-PRO-GAMING-ASUS-2003.zip


1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don't think this would work with previous versions.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode.

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install.

Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.

I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.

The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.

Hope this works for you.

Ivan
 

zzont1

Commendable
Sep 18, 2016
28
0
1,530
0


Can I get a MSI version of this ? :D
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS