Question Samsung 970 Evo 250 GB not detected during Windows Setup

Apr 3, 2020
7
0
10
0
Hi,

I have recently bought a new PC with all brand new parts. After assembly, I have come across the issue where the NVMe M.2 SSD could not be detected in Windows Setup. It is the only drive that exists in my PC. The drive is detected in the BIOS/UEFI without having to tweak anything, but when booting from a Win10 USB install, in the first step no drives can be detected.

I have looked at some existing solutions, such as:

- Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.
  • Click on secure boot option below and make sure it is set to other OS, not windows UEFI.
  • Click on key management and clear secure boot keys.
  • Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.
  • Press F10 to save, exit and reboot.
  • Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.
  • When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.
  • Click on secure boot again but now set it to WIndows UEFI mode.
  • Click on key management and install default secure boot keys
  • Press F10 to save and exit and windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.


Or using the repair tool in the Win10 USB installer to gain access to the CMD and format the NVMe using diskpart where the drive is detected as well, but no luck.

PC Specs:

AMD Ryzen 5 3600
Gigabyte Aorus X570 Elite
Corsair 16GB
Gigabyte Aorus RTX 2070 Super
Samsung V-NAND SSD 970 EVO Plus NVMe M.2 250GB
Corsair TX550M
 
Apr 3, 2020
7
0
10
0
in boot options, see if storage is set to uefi mode, windows doesnt like nvme in legacy mode

secure boot shouldnt matter if drive is new
Storage Boot Option Control > UEFI Only
Other PCI Device ROM Priority > Legacy Only


The only two setting I could find relevant. First one was in UEFI by default. The second option I changed to UEFI as well and no luck.
 
Apr 3, 2020
7
0
10
0
These are the formatting steps I used with CMD.
diskpart
list disk
(Disk 0 was the NVMe and Disk 1 was the USB)
select disk 0
clean
create partition primary
format fs=ntfs

Maybe I missed something.
 
Apr 3, 2020
7
0
10
0
Actually I just plugged in an old HDD through SATA and that is also not being detected. Possibly an issue with the Windows 10 install image or USB itself.
 

ASK THE COMMUNITY