Samsung 970 Evo 256GB Not Showing Anywhere

Dec 31, 2018
3
0
10
0
So I made the Jump to Z390 and purchased the Asus Maximus XI Hero, an Intel 8700k and 32GB of Corsair Vengeance Pro RGB DDR4. I also bought 2x M.2 NVMe drives in the form of the Samsung 970 Evo 1TB and 256GB drives.

I whipped it all together and booted it up to install Windows and was slightly disappointed to not find the 256gb drive in the bios. The 1TB drive was there but I initially planned to use that for games and the 256gb for my OS. So I tried switching the SSDs to see if maybe one of the ports needed activating or whatever, but no. Again only the terrbyte drive was showing. Hmmmm.

Oh well, maybe once I get Windows running I can initialize the drive through Disk manager...right? Wrong. It's not in disk manager, not in Samsung Magician or any other third party program.

I am struggling to believe that the drive is faulty, and as I am unfamiliar with the Asus board, I'm looking towards that as a the catalyst.

Another thing. Post and windows load up time is slow. And I mean S L O W. Post takes about 30-40 seconds and windows takes another 20 seconds or so. I've turned on fast boot and done the fast boot ption in the DDR timings menu too and it's made zero difference. I ran a performance check in Samsung magician and Im get the 3500 read and 2500 write speeds so it's not the drive. I started the build at lunch time on the 31st and it is now 4:08am on the 1st and I'm stumped. I've read tons of posts on here but nothing is resolving my issue. Absolutely devastated and completely out of ideas...So here I am.

To recap:

*I have 2x M.2 Samsung 970Evo NVMe drives. One is showing and One is not, regardless of ports used. The 256GB will not show in the Bios or anywhere in Windows.

*Boot time is incredibly slow. Even when I enable fast boot and

*Latest Bios version installed

*Only mouse and keyboard connected via USB

*Default and custom bios settings do the same thing

*UEFI Windows Install

I'm going to remove the 256GB drive as I just read a post where something similar happened. Will update if that is indeed the issue. If not....It wasn't.
 

ASK THE COMMUNITY

TRENDING THREADS