[SOLVED] Samsung 970 Evo M.2 SSD performing much worse than SATA SSDs

May 11, 2021
4
0
10
0
Hi everyone,

I have 970 Evo SSD connected to an older motherboard, an ASUS Z97 Pro Gamer via the M.2 connector, running at PCIe2 x2 speed - the fastest this board supports I believe. Reports as PCIe Gen2 x2 in Samsung Magician.

I know this is not the fastest this drive can run, however this card is being outperformed by the other SATA 3 SSDs (840 EVO and 870 QVO) in the system by a long way. This is via the Samsung Magician benchmark tool.

M.2 970 Evo
Sequential read: 823 MB/s
Sequential write: 798 MB/s


SATA 3 840 Evo
Sequential read: 3458 MB/s
Sequential write: 2254 MB/s


It’s actually closer to the level of performance of the SATA 3 2.5inch mechanical drive I have in the PC as a data storage, in sequential read/writes anyway…

what is going on with this? I wouldn't usually be too concerned with benchmark results but I looked into this as the PC seems to be quite slow with file transfers and Cyberpunk was bad with pop-in etc on the M.2 drive, when I moved it to the SATA one it was fine. Well as fine as Cyberpunk gets I suppose.

Any help would be great! All the newest updates and firmware are applied.

Cheers
 

Bob.B

Notable
Feb 8, 2021
1,057
121
890
15
Hi everyone,

I have 970 Evo SSD connected to an older motherboard, an ASUS Z97 Pro Gamer via the M.2 connector, running at PCIe2 x2 speed - the fastest this board supports I believe. Reports as PCIe Gen2 x2 in Samsung Magician.

I know this is not the fastest this drive can run, however this card is being outperformed by the other SATA 3 SSDs (840 EVO and 870 QVO) in the system by a long way. This is via the Samsung Magician benchmark tool.

M.2 970 Evo
Sequential read: 823 MB/s
Sequential write: 798 MB/s


SATA 3 840 Evo
Sequential read: 3458 MB/s
Sequential write: 2254 MB/s


It’s actually closer to the level of performance of the SATA 3 2.5inch mechanical drive I have in the PC as a data storage, in sequential read/writes anyway…

what is going on with this? I wouldn't usually be too concerned with benchmark results but I looked into this as the PC seems to be quite slow with file transfers and Cyberpunk was bad with pop-in etc on the M.2 drive, when I moved it to the SATA one it was fine. Well as fine as Cyberpunk gets I suppose.

Any help would be great! All the newest updates and firmware are applied.

Cheers
The 970 looks correct.....pcie2x2 equals 500MBx2 equals 1000MB/s.

The 840 is out of wack......do you have rapid mode set for that ssd?
 
May 11, 2021
4
0
10
0
Yeah it is, that’sa good idea actually. However i think I’m at the limit of PCIe Lane useage just now unless I want to split the GPU lanes down.

Annoying that the onboard slot isn’t working though. The fact it’s much slower than the SATA SSD indicates something is wrong? Even if it’s only PCIe gen 2 x2 that should still not be getting outpaced by SATA 3?
 
May 11, 2021
4
0
10
0
Argh. Really good point everyone. RAPID is on.
So probably this setup is OK then. I’ll have to go back to the drawing board with these random slight hang ups and performance issues etc that Windows has.
Thanks everyone.
 

ASK THE COMMUNITY

TRENDING THREADS