Question SAMSUNG 970 EVO Plus NVME M.2 SSD with PCIE card NOT WORKING - Won't INITIALIZE Windows 10 - - Orico expansion Card LENOVO M900

Mar 20, 2020
4
0
10
0
Hi
I have a Lenovo ThinkCentere M900 - posted on the Lenovo forum - no reply
I am having really big issues trying to get my ThinkCentre m900 to initialize my Samsung V-Nand SSD 970 Evo NVMe M.2 drive 500gb - via an Orico 16 slot Expansion Card in the bottom PCIe slot.
I've spent around 35 hours this week trying to solve this - I can not find one single case online where someone else has the same problem
The M.2 drive Shows up in Device Manager and in Control Panel > storage Spaces as well as BIOS
But it won't show up in Disk Manager, EaseUS Partition Master or SAMSUNG Magician
I have windows 10 as my OS on a Sata SSD - I have to re-install windows fresh to be able to see the M.2 drive in Disk Manager
But when I click the DISK UNKNOWN box to initialize I get an X ERROR saying 'Incorrect Function'
Then after doing that - Disk Manager will not open - same with EaseUS Partition Master
And the computer goes into a loop where it won't shut down - I have to pull out the power plug
When putting the power back on - it returns to the same loop
I can stop this by removing the M.2 from the PCIe slot
But windows must be re-installed fresh again for me to have another shot at this
Ultimately I want to use the Evo M.2 for my OS
But I can't even initialize it at all.
I have even made a Rufus UEFI Boot flash USB
But that does not work - when I get up to the part on the install where it asks 'WHERE DO YOU WANT TO INSTALL WINDOWS?' (with all drives unplugged except for the Evo M.2) there is no drive showing and it asks for my disk drivers - so I can't install Windows10 onto the Evo M.2
Is there a GENIUS out there who can tell me is it is possible to use this drive?
I have many screenshots of all errors etc
 

Maxxify

Distinguished
Aug 12, 2007
450
81
18,990
34
I think you have to disengage it from Storage Spaces first before it'll show in Disk Management. Someone else had this problem recently on one of the tech forums, I can see if I can find it but I believe that was the issue.
 
Mar 20, 2020
4
0
10
0

USAFRet

Titan
Moderator
Mar 16, 2013
124,655
4,085
159,940
19,592
Hey guys thanks fo rthe help - the Motherboard is:
ThinkCentre M900 Motherboard 03T7425
Lenovo support sent me an invoice for a 16 slot PCIe card adaptor - its a basic generic one from, Alibaba
and before sending me their 'invoice' they said that it will work with an NVMe PCIe adaptor
I had already bought the Orico adaptor
https://szchangyou.en.alibaba.com/product/62126765388-810993768/01AJ862_FOR_Lenovo_CARDPOP_PCIeX16_to_M_2_SSD_riser_LP.html
The drive will work in that adapter, as a secondary drive.
The motherboard may not be able to utilize that as a boot drive.
 
Mar 20, 2020
4
0
10
0
OK - I can't even initialize it as a secondary storage drive
I would LIKE to have it as my OS drive - but I'df at least like to be able to use it for storage
which is not possible for me yet!:unsure:
 
Mar 20, 2020
4
0
10
0
I looked up the part number from their 'invoice' - traced it to that link - Lenovo keep me hanging two weeks to supply me with the 'invoice' and its twice the price from Lenovo - but anyway I have the Orico adaptor
 

ASK THE COMMUNITY

TRENDING THREADS