[SOLVED] Samsung 970 EVO PLus NVMe M.2(V-NAND SSD) 500GB poor performance in games compared to older SSD

rigger922

Upstanding
Dec 7, 2018
146
0
260
16
Hello, guys and girls so i recently bought a 970 evo plus m.2 installed it today, set everything up all good to go.Moved over a couple of games from my older SSD(Samsung 840 EVO 256gb but i am getting poor performance on my new drive compared to my old one now i have done some research into this and am a little stumped on what to do as nothing i have tryed has fixed this. One thing that was mentioned was setting my bios to UEFI only ratehr then UEFI+Legacy but this requires me to reinstall windows 10 so i wanted to do this as a last resort,Please can you guys help. Also the guys on the other forum and such mentioned looking at Samsung magician for interface and mine says PCIe Gen 2 x 4.
 

Fix_that_Glitch

Commendable
Mar 31, 2019
1,683
131
1,440
43
You need to put the m2 in slot one it is pcie 3.0 x4. The slot you have it in is pcie 2.0 x4. The performance is cut in half at pcie 2.0 x4. Remember a ssd drive has no bearing on fps directly, but maybe the motherboard will perform better with the m2 in the first slot and you may see the change back in fps that way. Either way you will not see more fps.
 

rigger922

Upstanding
Dec 7, 2018
146
0
260
16
Well I can't be nothing else since everything else is up to date and nothing else has changed other then wilands has. Moved from my old ssd to. My new one and I've lost 10-20fps
 

Fix_that_Glitch

Commendable
Mar 31, 2019
1,683
131
1,440
43
You need to put the m2 in slot one it is pcie 3.0 x4. The slot you have it in is pcie 2.0 x4. The performance is cut in half at pcie 2.0 x4. Remember a ssd drive has no bearing on fps directly, but maybe the motherboard will perform better with the m2 in the first slot and you may see the change back in fps that way. Either way you will not see more fps.
 

rigger922

Upstanding
Dec 7, 2018
146
0
260
16
Well i moved the m.2 in to the other slot and it made no difference, However i found out that it was Wildlands causing the issue because other games i tryed had the or slightly better performace. I found this out when i moved wildlands back my older ssd and it was performing the same thnaks for the help guys.
 

ASK THE COMMUNITY

TRENDING THREADS