Question Samsung 970 Evo Plus NVMe slow speed

Nov 5, 2019
4
0
10
0
I recently purchased a new 970 Evo Plus M.2 (2 TB). Plugged it in, installed the accompanying driver and software (Samsung Magician), and it works... at a slow speed.



This is just a tad below the advertised speed of 3500 mb/s...

I already updated my mobo's BIOS, to no avail. All the tips I found floating around on Google concerning the BIOS settings, seem to be set up that way already on my system (boot up in AHCI, turn off MXP, ...).

Temperature wise, the drive is at a nice, stable 38° C, so that can't be the issue either.

My specs:

CPU:
Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
RAM:
DIMM2: G Skill Ares F3-1866C10-8GAB 8 GB DDR3-1333 DDR3 SDRAM (10-9-9-24 @ 666 Mhz) (9-9-9-24 @ 666 Mhz) (8-8-8-22 @ 609 Mhz) (7-7-7-20 @ 533 Mhz) (6-6-6-17 @ 457 Mhz) (5-5-5-14 @ 380 Mhz)
DIMM4: G Skill Ares F3-1866C10-8GAB 8 GB DDR3-1333 DDR3 SDRAM (10-9-9-24 @ 666 Mhz) (9-9-9-24 @ 666 Mhz) (8-8-8-22 @ 609 Mhz) (7-7-7-20 @ 533 Mhz) (6-6-6-17 @ 457 Mhz) (5-5-5-14 @ 380 Mhz)
GPU:
NVIDIA GeForce GTX 1070
MB:
Gigabyte GA-Z97X-UD3H
STORAGE:
SAMSUNG HD103SJ (1 TB, 7200 RPM, SATA-II)
Samsung SSD 850 EVO 250GB (250 GB, SATA-III)
Samsung SSD 970 EVO Plus 2TB (1863 GB)

So if anyone has any pointers, that'd be great.
 
Nov 5, 2019
4
0
10
0
Oh wow, my dumb brain has consistently misread that as pcie 3,instead of socket 3.

I am an idiot. Mystery solved.

I could potentially fix this with an expansion card?
 
Oh wow, my dumb brain has consistently misread that as pcie 3,instead of socket 3.

I am an idiot. Mystery solved.

I could potentially fix this with an expansion card?
yes expansion card will work

a side note
bottom pci-e x16 slot can run in x4 mode (needs to be configured in bios)
but only in pcie 2.0 mode, thats still faster than current speed

1st and second x16 slots caan be used for 3.0 speed, but it will slightly slower your gpu
 

ASK THE COMMUNITY

TRENDING THREADS