Question Samsung 970 EVO showing in BIOS, not in Device Manager, not in Disk Management

Apr 16, 2020
1
0
10
0
Bought the Samsung 970 EVO SSD for some new storage on an already existing build.
  • Motherboard: ASRock AB350 Pro4
  • CPU: Ryzen 5 2400G (used this before I could afford the GPU)
  • GPU: Geforce GTX 1060 6GB
  • Existing SSD: Western Digital Blue 2.5" SSD (SATA)
  • Existing HDD: Toshiba P300 3.5"
Windows is currently installed on the WD Blue SSD.

Problem: The new Samsung 970 EVO is showing up in BIOS but it is NOT in Device Manager and it is NOT in Disk Management.

It is currently connected to the M2.1 slot as directed by the MB manual. I have tried using the M2.2 slot but to no avail.

I've tried switching MB from AHCI to RAID mode - when I do this the PC can't boot Windows at all and just crashes.

Sidenote: With the Samsung SSD connected the PC hangs at the BIOS splash screen for 10-15 seconds. It does not do this if I disconnect the Samsung SSD.

Any help would be greatly appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS