Question Samsung 970 m.2 shows up in bios but no boot option

Sipan9000

Reputable
Aug 10, 2015
96
15
4,565
5
Ive just built a new pc and i cant get the m.2 to show up as a bootable option, i have it set up right and the bios detects it when i check ezmode but there is no option to boot from it.

System:
Ryzen 9 3900x
Asus rog strix x570-e
850w evga psu
GSkill 2x16 3200mhz royale
Nzxt 360mm aio
Evga 2080ti

This is the 4th system ive built with an asus strix motherboard that ive tried booting from m.2 and it is the only one thats having this problem, all the others booted on the m.2 without me having to touch bios.

Csm is off , i have tried all the secure boot settings too but nothing works. Even swapped slots and still nothing. Im sure the m.2 is working because the bios is detecting it in slot one but im picking up another one tomorrow just incase

Help me out pls because i have no idea at this point
 

Lutfij

Titan
Moderator
Are you on the latest BIOS update for your motherboard? If you have other storage devices connected to the platform, disconnect them and see if the installer picks up on the drive. Also did you create your bootable installer for Windows 10 using Windows Media Creation Tools(to be on 1903)?
 

Sipan9000

Reputable
Aug 10, 2015
96
15
4,565
5
Are you on the latest BIOS update for your motherboard? If you have other storage devices connected to the platform, disconnect them and see if the installer picks up on the drive. Also did you create your bootable installer for Windows 10 using Windows Media Creation Tools(to be on 1903)?
I did try updating to latest bios but that did nothing, also tried disconnecting everything else and there were no boot options at all, as of now all that shows as a boot option is my flash drive for windows 10
 

ASK THE COMMUNITY

TRENDING THREADS