Question Samsung a350 monitor weird backlight "ramp-up" after turning on ?

May 12, 2022
1
0
10
0
I have samsung SyncMaster SA350 monitor, and for some time now it has had a weird behavior after turning it on after a long (for example overnight) period of it being off:

At first stage it turns on, indicated by small led, but then displays some kind of testing screen with red, green, blue and white gradients, then turns off, then turns on again and get stuck in this loop for about 10 minutes

At second stage it still gets stuck in a turn on - turn off loop, but displays almost nothing, but i can see a faint white horizontal line (backlight is off at this moment so i cant tell much, it might be a top piece of image sent to monitor) that moves a step down every turn on cycle

And at third stage it finally displays an image, but backlight is very dim, and its brightness depends on screen contents: if i open fullscreen youtube in dark mode i cant see almost anything, but if i switch it to light mode backlight brightness increases alot. It stays in this state slowly ramping the brightness up, but even after complete ramp-up it is still dependent on screen contents as described before

What could this be? I opened it up, and caps look fine, it had a faulty power connector that had bad contact so i replaced it, but it did not change anything, except fixing screen flickering when connector was wiggled around. I also tried reflashing monitor firmware with samsung's tool, as i had to do this once when this monitor stopepd working, but tool said that firmware did not need an update
 

ASK THE COMMUNITY