Question Samsung Ativ 9 laptop won't boot

anvoice

Prominent
Jan 12, 2018
19
1
515
0
Hello, I have a Samsung Ativ 9 laptop (PN930X2K-S02US) that will not boot most of the time. The power light does come on, although I don't hear any noise (it's a fanless design with an SSD so nothing to hear). I did manage to get it to boot 2 times out of dozens of attempts.

Whats I tried:
  • Removing the battery and powering the laptop through its charger. Problem persists, although there were 2 (out of a few dozen) times that the computer booted.
  • Checking various connections and ribbon cables. Visually nothing looks broken.
  • Checking for excessive heat generated on the motherboard (appears reasonably cool).
Because the problem is intermittent, and the laptop was powered off for a fairly long time, I suspected the CMOS battery. However, after partially taking the laptop apart, I can't find it no matter how hard I look. I attempted to search for either 2 small wires going to the motherboard, or a physical round CMOS battery on the motherboard itself, and found nothing.
I did find a RTCRST text on the back of the motherboard, but still not seeing the battery itself. Here is the opened laptop:


I'm a bit lost at the moment, and would really appreciate any advice. Does anyone know where the battery might be on this laptop?
 

anvoice

Prominent
Jan 12, 2018
19
1
515
0
A little bit of new info: I've tried many dozens of times to turn the computer on and off. It only boots without battery, and even then very intermittently. If the battery is unplugged, I can get one more reaction from the computer - if I unplug the charger and plug it back in, then power the laptop, a light on the caps lock key briefly blinks. That seems to be a necessary but not sufficient condition for the laptop to boot. Also, there does not seem to be a CMOS battery in this computer. I can buy another laptop battery for about $50-60, but I can't figure out why, if it's a bad battery, it only rarely boots even with battery disconnected. As a final detail, the battery voltage is 8.2V, right about where it should be fully charged, so I don't even know if the battery is bad.

Would really appreciate any and all advice.

Small Edit: it also seems that the computer is more likely to boot if I plug in the battery, then unplug it, push the power button for 15 seconds, plug in the charger and power the laptop on.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS