Samsung ML2165W laser printer freezing applications.


Sep 14, 2012
This is sort of difficult to explain, so try to bear with me for a moment.

I purchased a Samsung ML2165W about a month ago. Set it up and have been having this odd issue. The printer will print fine, maybe on 5 times in a row, maybe 10, maybe just once. Then it will stop working. What I mean by that is when I click print, the application freezes. Take firefox for example, when you click print, the window pops up asking you to chose a printer. After this issue has occurred, this window does not pop up, instead Firefox crashes and needs to be closed. This will continue until the computer is restarted.

Then I also run into another odd issue where changing the color of font in Excel freezes the application in a similar fashion. I googled the problem and found that it's related to printer drivers, so I put 2 and 2 together and narrowed it down to the driver. Samsung offers 2 drivers, one as a .exe and another used when you do the "add printer" function. Neither worked.

To add to it, I have run into another issue with this. I am a seller on eBay, and I have label printing down to a science. I print labels directly from eBay using a Dymo LabelWriter 450 Turbo and prior to printing, eBay displays a "preview" of the label using Java in an independent application. This process I follow has me engaging a label print nearly simultaneous to when I print a packing slip using the Samsung. Could this be an issue? I have tried to slow it down so that I wait for the label to print, then print on the Samsung but no go. And as mentioned, it's random when it happens. I can print 18 packing slips in a row with no issue, other times it may happen after 3 or 4, so maybe it's some sort of caching issue?

It's not particular to the computer either, it does it both on a brand new build, and an older laptop both with W7 Ultimate. It's driving me damn crazy because every time it happens, a restart is required to fix it. I've tried every combination of driver etc but cannot fix this problem. Google is no help either.