Samsung monitor flash on and off randomly

Dec 31, 2018
1
0
10
0
Just built a new PC and connected it to a Samsung 28" UE590 UHD Monitor. The monitor came with an HDMI and a Displayport cable. When I connect the monitor to my graphics card with HDMI the monitor will go black and after a second it will turn back on. A HDMI sign is displayed on the top right corner of the monitor when the monitor goes back on like it just got connected. It will do that randomly throughout the day. So I decided to use a different port for both monitor and graphics card. The random black screen was gone but I get static lines like the connection was bad. When I use the Displayport its usually fine, although sometimes I get slight blinking (monitor flashes to black for a fraction of a second). At first I thought I bought a bad monitor so I returned it and replaced it with another one, but it had the same issue.

I checked all the cables and power are plugged in properly. I used the HDMI cable with my tv without issue and used the monitor with my laptop without issue. So that leaves the culprit to either the hardware (graphics card or motherboard) or my drivers I think. I don't know which it is.

Graphics card: MSI Radeon RX 580 Armor MK2 8G OC
Motherboard: Gigabyte Z390 AORUS Ultra

Both have latest driver installed.

I manage to catch it on video. Here's a link.


https://drive.google.com/file/d/1CF6Had-1EZJmmlPiLNH5WOCkn2gtIjAW/view?usp=sharing
https://drive.google.com/file/d/1noSjqL1TQljJ4ehV3g60GktKzRWECzpx/view?usp=sharing


Thanks for your time!!!
 

eugue2000

Distinguished
Aug 8, 2008
4
0
18,510
0
I am having a problem with the HDMI port on my Gigabyte Aorus RX 570 graphics card, too. The display port works fine, but the output from the HDMI port causes the screen to flash off and on in a regular pattern (on for about 1 second and off for about 2 seconds). I have tried a different monitor and different cables with no effect. The Radeon software and drivers are at the current levels.

I found a YouTube video that recommends turning the "Problem Reports and Solutions Control Panel" and the "Windows Error Reporting Services" off in the services tab of msconfig (
View: https://www.youtube.com/watch?v=qXCsdaBnlnA
). This fixed the issue. But, I am wondering if there is anything more to this. I would think that those services are important and should be kept active.

The monitor is a Dell S2719DGF running at 144Hz with a resolution of 2560x1440. I have the DP port and the HDMI port set as "Duplicate these displays". The graphics card is connected to a PCIe x16 slot. Here is the graphics card information:

Radeon Software Version - 19.4.1
Radeon Software Edition - Adrenalin 2019
Graphics Chipset - Radeon RX 570 Series
Memory Size - 4096 MB
Memory Type - GDDR5
Core Clock - 1280 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 16 GB
CPU Type - Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Motherboard - Gigabyte Z390 Aorus Master

I do not need the HDMI port to work as the DP is working fine. But, I want to be able to change my monitor configuration to "Extended these displays" so I can have different work on both ports.

Any suggestions would be appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS