Question Samsung Odyssey G7 Display disconnecting issue

Jul 15, 2021
2
0
10
0
I recently bought the 1440P, 240hz G7 Odyssey 32" monitor. My monitor is connected via display port into my PC.
However , every time my monitor goes to sleep, after I wake it up, it keeps disconnecting then reconnecting. It happens mostly when I try to maximize a window such as google chrome.
This issue also occurs when I switch my display source from HDMI back to Display port.
I've tried using another DP cable but didnt help.
Any idea why this happens? Do I have a faulty monitor?
 

alexbirdie

Notable
Feb 20, 2020
415
83
840
38
I do not have this issue.

Newest firmware is from last year Version 1009.3 .

If not yet installed(you can check it with the monitors OSD), get it from samsung, check the firmware-installation-guide and update your firmware ( I did it, and it is very easy, no problem occurred, you only need an USB-stick).

If the issue still occurs afterwards, than either the monitor is bad OR there is a bug with your GPU.

I would try it with another GPU and/or with another monitor.
 
Jul 15, 2021
2
0
10
0
I do not have this issue.

Newest firmware is from last year Version 1009.3 .

If not yet installed(you can check it with the monitors OSD), get it from samsung, check the firmware-installation-guide and update your firmware ( I did it, and it is very easy, no problem occurred, you only need an USB-stick).

If the issue still occurs afterwards, than either the monitor is bad OR there is a bug with your GPU.

I would try it with another GPU and/or with another monitor.
I do not have this issue.

Newest firmware is from last year Version 1009.3 .

If not yet installed(you can check it with the monitors OSD), get it from samsung, check the firmware-installation-guide and update your firmware ( I did it, and it is very easy, no problem occurred, you only need an USB-stick).

If the issue still occurs afterwards, than either the monitor is bad OR there is a bug with your GPU.

I would try it with another GPU and/or with another monitor.
I do not have this issue.

Newest firmware is from last year Version 1009.3 .

If not yet installed(you can check it with the monitors OSD), get it from samsung, check the firmware-installation-guide and update your firmware ( I did it, and it is very easy, no problem occurred, you only need an USB-stick).

If the issue still occurs afterwards, than either the monitor is bad OR there is a bug with your GPU.

I would try it with another GPU and/or with another monitor.
I do not have this issue.

Newest firmware is from last year Version 1009.3 .

If not yet installed(you can check it with the monitors OSD), get it from samsung, check the firmware-installation-guide and update your firmware ( I did it, and it is very easy, no problem occurred, you only need an USB-stick).

If the issue still occurs afterwards, than either the monitor is bad OR there is a bug with your GPU.

I would try it with another GPU and/or with another monitor.
Thank you.
Ill have to try firmware update.
I dont think the GPU is the issue since i've had no problems with my old monitor.
 

ASK THE COMMUNITY