[SOLVED] Samsung SSD's showing as SCSI Disk Device

YoItsJgun

Prominent
Dec 9, 2019
1
0
510
0
Hello, I recently have been having a problem with both my SSD's. First off I have a 970 EVO and an 860 EVO both drives have this problem. I had first noticed this when I was trying to benchmark on Samsung magician it was telling me my drives were unknown. I've searched all around and cannot find any solution. Thank you in advance to those who respond :)

Mobo: ASUS ROG Strix B450-F

ScreenShots:

 

Palorim12

Distinguished
May 3, 2013
756
5
19,365
111
Hello, I recently have been having a problem with both my SSD's. First off I have a 970 EVO and an 860 EVO both drives have this problem. I had first noticed this when I was trying to benchmark on Samsung magician it was telling me my drives were unknown. I've searched all around and cannot find any solution. Thank you in advance to those who respond :)

Mobo: ASUS ROG Strix B450-F

ScreenShots:

Usually happens when your SATA controller is set to RAID mode in the BIOS. Check your BIOS and if it is, do the following to switch to AHCI (edit If you're on Windows 10):

  1. Run MSCONFIG in Windows
  2. Enable Safe Boot (minimal)
  3. Reboot into UEFI/BIOS and change to AHCI
  4. Boot up into safe mode
  5. Run MSCONFIG and disable Safe Boot.
  6. Reboot
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Are both SSD's on the latest firmware's? On second thought's might want to see what BIOS version you're currently on for your motherboard. If you have BIOS updates to go through, make sure you gradually work your way to the latest version, taking note of any chipset or MEI drivers that might need updating along the way.

What is the storage controller in your BIOS set to? It should be AHCI.
 

Palorim12

Distinguished
May 3, 2013
756
5
19,365
111
Hello, I recently have been having a problem with both my SSD's. First off I have a 970 EVO and an 860 EVO both drives have this problem. I had first noticed this when I was trying to benchmark on Samsung magician it was telling me my drives were unknown. I've searched all around and cannot find any solution. Thank you in advance to those who respond :)

Mobo: ASUS ROG Strix B450-F

ScreenShots:

Usually happens when your SATA controller is set to RAID mode in the BIOS. Check your BIOS and if it is, do the following to switch to AHCI (edit If you're on Windows 10):

  1. Run MSCONFIG in Windows
  2. Enable Safe Boot (minimal)
  3. Reboot into UEFI/BIOS and change to AHCI
  4. Boot up into safe mode
  5. Run MSCONFIG and disable Safe Boot.
  6. Reboot
 

ASK THE COMMUNITY

TRENDING THREADS