[SOLVED] Samsung TV no longer connects to Blu-ray players ?

Jul 8, 2021
1
0
10
0
Just like this post my Samsung TV ( Model: LA40A650A1F) stopped working with my Soniq Blu-ray player that it has always played fine with.

One day it just said "Searching for signal" and "Mode not supported"

I tried:
*Using a different port - no help
*Using different HDMI cables - no help
*Testing the Blu-ray player on another TV - it worked fine on a different TV!
*Putting the TV in "movie mode" as was suggested by a responder in the post above - no help.
*Called Samsung - reset firmware no help
*Called Soniq (Blu-ray manufacturer) reset firmware - no help.
*Sold the Blu-ray as it still worked and purchased a different one: Samsung 3D Blu-ray player.
*Connected the new Samsung Blu-ray player to the Samsung TV - the new Samsung Blu-ray player doesn't work either!

All other device work fine through any of my HDMI cables, on any of the HDMI ports: Xbox 360, XBox One S, Apple TV, PS3, Raspberry Pi 3 Raspberry Pi 4, Google Chromecast - but something unique to Blu-ray players only seems to be causing a problem. What on earth could it be. It is as if the clock ticked over past a certain date and a licence expired or something!

Anyone know what is going on here?
Thanks!
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS