SanDisk Cruzer mini 128Mb

vertical

Distinguished
May 30, 2004
4
0
18,510
0
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hello! This will be a rather long post about how I got my Cruzer mini to work with my IBM Thinkpad running WinXP SP1.

I have read several threads here on the subject of SanDisk Cruzer mini and how it fails to mount properly in windows for various reasons, but I have never read an actual solution to the problem. I recently baught a Cruzer mini for my IBM Thinkpad T23 running WindowsXP SP1. The unit was manufactured in Taiwan and was the 128Mb modell. I installed the Cruzer in the USB1.1 port of my thinkpad but windows kept saying hardware malfunction no matter what I tried. The Cruzer worked perfectly fine with all other computers around (Win98SE, Win2K, WinXP. USB2.0 or USB1.1) but not in mine. I tested a freinds USB1.1 memorystick which mounted perfectly. So.. I went back with the Cruzer to return it and ofcourse the salesperson offerd me to try a new Cruzer mini. I thaught that was a stupid idea as he also could see that the Cruzer was not compatible with my Thinkpad but why not! And what do you know?! The new Cruzer mounted correctly. The only difference I can see is that the new Cruzer is of a newer batch manufactured in China this time. I baught the new Cruzer not knowing exactly why it solved the problem. (I still don´t)

The story could have ended here but here comes the kicker!

Later, a friend of mine baught my old Cruzer mini and for some reason I don´t remeber we connected my Thinkpad to a generic USB1.1-hub with external power and put the old Cruzer in the hub and in this configuration even the old Cruzer mounts correctly. It works without a hitch. So I tried the old Cruzer again directly in the ports of my computer but a no go again. Why is this? Is my USB-ports on the back of my Thinkpad not able to deliver enough power to the Cruzer mini? Is the Cruzer not entierly backwars compatible with USB1.1? Why did the new Cruzer mini from China work and not the first one from Taiwan? I don´t know, but my reccomendation is that before you send your memorystick back, test it in an external hub first.
/ Vertical
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

One of possible reasons (just a long shot - can't be sure without seing the device) can be
wrong definition of power requirements in USB descriptors.
So it works thru a self-powered hub, but when connected directly, XP thinks it hasn't enough power.

--PA

"Vertical" <anonymous@discussions.microsoft.com> wrote in message
news:1DD008B9-F8AB-49EB-81A7-DE616C3A2781@microsoft.com...
> Hello! This will be a rather long post about how I got my Cruzer mini to work with my IBM Thinkpad running WinXP SP1.
>
> I have read several threads here on the subject of SanDisk Cruzer mini and how it fails to mount properly in windows
for various reasons, but I have never read an actual solution to the problem. I recently baught a Cruzer mini for my IBM
Thinkpad T23 running WindowsXP SP1. The unit was manufactured in Taiwan and was the 128Mb modell. I installed the Cruzer
in the USB1.1 port of my thinkpad but windows kept saying hardware malfunction no matter what I tried. The Cruzer worked
perfectly fine with all other computers around (Win98SE, Win2K, WinXP. USB2.0 or USB1.1) but not in mine. I tested a
freinds USB1.1 memorystick which mounted perfectly. So.. I went back with the Cruzer to return it and ofcourse the
salesperson offerd me to try a new Cruzer mini. I thaught that was a stupid idea as he also could see that the Cruzer
was not compatible with my Thinkpad but why not! And what do you know?! The new Cruzer mounted correctly. The only
difference I can see is that the new Cruzer is of a newer batch manufactured in China this time. I baught the new Cruzer
not knowing exactly why it solved the problem. (I still don´t)
>
> The story could have ended here but here comes the kicker!
>
> Later, a friend of mine baught my old Cruzer mini and for some reason I don´t remeber we connected my Thinkpad to a
generic USB1.1-hub with external power and put the old Cruzer in the hub and in this configuration even the old Cruzer
mounts correctly. It works without a hitch. So I tried the old Cruzer again directly in the ports of my computer but a
no go again. Why is this? Is my USB-ports on the back of my Thinkpad not able to deliver enough power to the Cruzer
mini? Is the Cruzer not entierly backwars compatible with USB1.1? Why did the new Cruzer mini from China work and not
the first one from Taiwan? I don´t know, but my reccomendation is that before you send your memorystick back, test it in
an external hub first.
> / Vertical
 

vertical

Distinguished
May 30, 2004
4
0
18,510
0
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

hello Pavel

I don´t get the Low power warning from Windows. Windows just says that the device has malfunctioned. Windows suggests reconnecting it to solve the problem but that obviously does not work. It works through the self-powerd hub yes, but not directly in the computer.

/ Vertical

----- Pavel A. wrote: -----

One of possible reasons (just a long shot - can't be sure without seing the device) can be
wrong definition of power requirements in USB descriptors.
So it works thru a self-powered hub, but when connected directly, XP thinks it hasn't enough power.

--PA
 

ASK THE COMMUNITY