Sapphire 3650 HD AGP on an old system - serious issues


Sep 1, 2009
Hi there,

It's been a long time since I built my PC, probably 6 years.
I don't have much time to play games these days so I wouldn't want to buy a new machine, but lately I thought about upgrading it a little so it could run WoW smoothly with nice and shiny graphics.
So I went and picked up a Sapphire 3650 HD AGP with 512mb DDR2 and thought "Well, it must at least blow WoW away...".

My system specs right now:

CPU: Intel Pentium 4 3.0GHz
MB: ASUS P4P800 (not deluxe or anything)
RAM: 2x 1GB of Kingston 400MHz DDR CL3
PSU: A 500W max output PSU, not something familiar
OS: Win XP Pro SP3
Old GFX card: ATI Radeon 9800XT (it used to be a beast! ;) )

Now back to the subject.
I installed the new 3650 card, turned on the PC, Windows loaded, and the next thing I saw is "Found new hardware", except I had 2 of these... Strangely, my Realtek RTL8139 Ethernet NIC lost its' drivers somehow... I tried to install it again by simply uninstalling and reinstalling it in the device manager and it lost the yellow "!" mark, but it didn't really help because I had no internet or LAN connection even though I got a "Local Area Connection" in the network connections folder.
Meanwhile I got some BSODs with a NDIS.sys and "Driver not equal" kind of errors... but it only happened every 5 minutes so I managed to do some work from one crash to another.
I figured it was just a driver problem and once I install the GFX card's drivers it would solve the network issue.
So I downloaded (from another computer) the latest ATI drivers for the 3600 series (Actually, it was from Sapphire's site). It was the "Hotfix for AGP" version. I installed them and my GFX seemed to be working as expected, although I still had network issues. Somehow by uninstalling and reinstalling the network card itself, aswell as the drivers for it, I got my connection back. Now everytime I reboot my PC I lose the internet connection, even though it's installed correctly in the device manager. So my temporary (and very annoying) solution is to reinstall it in the device manager everytime I reboot.
I then left the network issue alone and wanted to see some action from the new GFX card. I opened up WoW and expected to see high FPS in the login screen, but for some reason I got even less FPS then I had with the 6 year old 9800XT. It wasn't like 2-3 FPS but not something I would expect from this card.
I started to google the web for solutions.

Things I've tried:
- Install older GFX drivers.
- Raise the AGP aperture size from 64 to 256 in the bios (256 was the max, but the card has 512mb ram... does it matter?).
- Checked the core and memory values.
- Remove the network card and see how it runs without it.
- Downloaded new drivers for the network card.
- Connect the power supply of the GFX card straight to the PSU.
- Checked dxdiag > display tab, everything is enabled.

That's it basically, I can't remember what else I tried. I'm pretty sure that the card is connected correctly, also the power supply of it. I don't really know where to continue from here, I don't even know if it's a hardware or software problem.

Please help me with this,
Thanks in advance.


Aug 27, 2006
Could you try cleaning the port of the video card with either canned air or with a compressor and try cleaning the gold contacts with a pencil eraser (just make sure to remove all the eraser bits before reinserting).

I'm not really sure if you also need driver cleaner since it is an ATI to ATI transfer, but it might be worth a shot.
Update your USB drivers. With AGP Radeon cards, especially using an older driver set, this can be a huge issue. In your BIOS disable AGP Fast Read and Fast Write as it will improve your stability. If you still have trouble it could be a resource sharing problem as previously suggested. You can go into your BIOS and if it has "Plug and Play OS" you should disable that and the motherboard will try to assign those values itself. Of course that could create other problems if you have alot of devices and your motherboard doesn't make good choices :D.


Sep 1, 2009
Thanks for the replies fellas.

amnotanoobie, I tried a driver cleaner app and it didn't change anything. Will try to clean up the ports later today.

4745454b, the net card's IRQ (when it's working) is 21 and the GFX card's is 16.

megamanx00, tried to disable AGP Fast Read and Fast Write - didn't help. Couldn't find where to update the USB drivers :S nothing on And Plug and Play OS was already disabled when I entered the bios...


Sep 1, 2009
I'm starting to think that maybe my GFX card is bottlenecked by the CPU... at least on WoW as I heared it is a very CPU-demanding game. I will try some other games soon... and the explanation for the "lower fps than before", well I guess that now the card supports more shaders and stuff so more never-seen-before graphics make the CPU do more calculations. Tell me what you think.

I'm still struggling with the network card conflict though.


Yes, but now with the new video card, your lan might be conflicting with your sound card. Or some other device. As I said, check both the video card and the lan, make sure both are on their own channel seeing as your having issues with them. Not sure it will fix the problem, but its the only idea I have.