Question Sapphire FirePro S10000 x2 only using 1 GPU

Jan 12, 2022
2
0
10
0
Hey there!
I´m really loosing it.
I got my hands on a brand new FirePro S10000 and it seems to work.
Sadly, only one GPU works.
Both are recognized in Windows 10 and even FurMark sees both but no matter what application I run, only one GPU is at 100% while the other is at 0% load.
Radeon Pro software sees both GPUs but the second one is just disabled, with no way of enabling it.
There are no options for Crossfire.
Tried all kind of drivers, nothing works.
Do you actually need a motherboard that supports Crossfire for a dual GPU card?

My setup:
Huananthi X99 8F-M Board (I know i know chinese)
Intel Xeon E5-2673 v3
8GB DDR4 ECC RAM
Samsung EVO SSD
750W EVGA PSU with enough power on 12V to supply the card

I would be very thankfull for any further help.
 
Jan 12, 2022
2
0
10
0
what application are you testing? can't find any spec on this chinese motherboard
test 1 gpu on all the pcie x16 slot?
It only has one PCI E x16 slot.
Couldn't find anything in the bios.
I tried FurMark, GTA 5, ARK Survival Evolved and even tried windows 8.1 because that's the last support OS.
I feel like the Mainboard is causing the problem.
I recently returned a GTX 690 which is also a dual gpu, that hat lots of performance and crashing problems.
 

ASK THE COMMUNITY