Question Sapphire RX 480 Nitro 4GB Display Issue/Driver issue?

Jul 8, 2021
3
0
10
0
Hello,

A bit of backstory first:
I have bought a couple of cards not too long ago (8x Sapphire Nitro RX 480 4GB). I have sold or used 7 cards in the meantime, but I still had one left to put in a pc to eventually sell.

I was wondering what all this mining fuss was about so I tried to give it a go with a my Sapphire RX 480 4G and a ASUS DUAL RX 480 4G. I used HiveOS with TeamRedMiner. My ASUS RX 480 was running fine, but after about 20 seconds I got the notification in HiveOS that GPU0 was defective (that would be my Sapphire card). Of course I inmeadiately turned off my testbench and had a look.

Here I am now, having this really strange issue.

The issue:
The Sapphire RX 480 4G does not display until in Windows. It works in a really strange way where the card ONLY gives display if there is any sorts of AMD drivers installed. So that would be in Windows, ofcourse.
During the entire boot sequence, i.e the BIOS splash screen, Windows boot screen I get no picture, only when I get into Windows. I have tried reflashing the BIOS, but it didn't change anything. My mate who just happens to have the same card, sent over his BIOS, to see if maybe that was the problem, but it just said in AMDVBFlash that the same BIOS was already installed. Same issue with the bios from techpowerup. It only shows picture in Windows.

I could not find any burnt or damaged components on the board when disassembled, the thermal paste is original, might be an issue but I'd like to ask here first before I try anything else.

Noteworthy; the card LEDs work and the fans do also work. The card does only go into 0rpm mode when drivers are installed (confirmed that by DDU-ing the drivers). So during the entire boot sequence the fans are running at like 30-40% fan speed. I'm gonna ask my mate if he has the same thing with his card, which does actually work correctly.

My testbench:
Intel Core i7-6700K
MSI Z170A SLI PLUS mobo
HyperX Fury DDR4-2400MHz
NEW Evga 600BR PSU (only has been on for like an hour or so)
And of course my ASUS RX 480 DUAL OC 4GB
and Sapphire Nitro RX 480 4GB

The way I install my drivers: booting via the IGPU and installing the drivers, which then allows me to boot from the card and get display out. Or I just straight up go into windows booting from my RX 480, and then I will eventually get display when Windows automatically installs drivers.

I have not yet ran Furmark, I need to know first if thats a good idea.
My other components are not the issue. Ruled that out because my ASUS RX 480 DUAL OC works perfectly, in the same PCIe slot, same power cable.
It's something related to my Sapphire GPU.

The reason I want to fix this, is because I plan on building a PC with this GPU and selling it. I want to make sure that somebody that buys my PC does not get a poorly functioning card.

I do not have a multimeter on hand, so I can't really test resistances and stuff.

Thanks in advance.
 

ASK THE COMMUNITY

TRENDING THREADS