SATA drives and RAID....help!

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
All I wanted was 2 hard drives, partitioned so I would have plenty of space for backups, my mp3's, movies and pictures. Now I have some sort of RAID array 0-1 (?) and don't want it! I've already installed win2k (after ALOT of headaches) and was wondering if there was any way I could get rid of this 'array' and get windows to see both drives and be able to use all my space? (and hopefully without having to reinstall windows but if I have to then so be it) I've asked other forums but never got an answer. This is a new pc too by the way....that (brilliant me) ordered without an OS (thinking I could do this without too much pain....boy was I wrong!) :cry: I'm only hoping some brilliant member here will be able to help me! :D

Thanks ahead of time!
Deb

Sorry...forgot my specs:
1 WD SATA 7200 rpm w/8mb cache 160 GB
1 WD SATA 7200 rpm w/8mb cache 80 GB
AMD SEMPRON 3100+ processor
Biostar K8M800-M7A mobo
Via Chipset VT8237R

Is that all you need?
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
All I wanted was 2 hard drives, partitioned so I would have plenty of space for backups, my mp3's, movies and pictures. Now I have some sort of RAID array 0-1 (?) and don't want it! I've already installed win2k (after ALOT of headaches) and was wondering if there was any way I could get rid of this 'array' and get windows to see both drives and be able to use all my space? (and hopefully without having to reinstall windows but if I have to then so be it) I've asked other forums but never got an answer. This is a new pc too by the way....that (brilliant me) ordered without an OS (thinking I could do this without too much pain....boy was I wrong!) :cry: I'm only hoping some brilliant member here will be able to help me! :D

Thanks ahead of time!
Deb

Sorry...forgot my specs:
1 WD SATA 7200 rpm w/8mb cache 160 GB
1 WD SATA 7200 rpm w/8mb cache 80 GB
AMD SEMPRON 3100+ processor
Biostar K8M800-M7A mobo
Via Chipset VT8237R

Is that all you need?
Sometime, to use SATA HDD, on some motherboard with VIA controller, you need to create single HDD array. It may be the case. If you are seeing 2 HDD, with the correct size, then this is what you had to do. But, if you are seeing only one HDD, with 80 gigs, then you have created an array.

In this case, I suggest to take out the drive that won't hold the OS, and reinstall with only one hdd. Then plug back the second HDD after.
 

Codesmith

Distinguished
Jul 6, 2003
1,375
0
19,280
0
You should have no problem backup your OS partition with something like True Image 8/9 (maybe to DVD+RW or an external hard drive).

Then restore to non-RAIDed hard drive.

Usually you only expect to have problems going in the other direction (non RAID to bootable RAID).

That is assuming that you are in fact actually using RAID and not some sort of Single Drive JBOD Array (which = non-RAID mode) required by many SATA controller.

You should of course be using something like True Image 8/9 anyway to protect all your hard work. Last week I updated all my apps and suddenly my system got a little weird. Since I took 7 min to create a backup first I was back in working order in less than 15 min. A clean install of all my apps, plus correctly configuring all my software would have wasted an entire day. I use an anattened install CD and XP Autopatcher, but I install all my other programs by hand.
 

TechGuy81

Distinguished
Apr 4, 2006
16
0
18,510
0
Ok here is your solution...

Boot up your computer, during boot there should be an option to enter the RAID config tool...usually pushing the TAB key during a boot will take you to the RAID menu. You'll have to delete the RAID Array, which means losing all of your information...trust me this is a lot easier than trying to back up or create an image of your current setup...

Next...
Go into BIOS and change your Boot drive to CDROM as primary and one of the two available drives as secondary. Now that you have deleted your boot array it should show two seperate drives instead of one RAID drive...disconnect any other devices such as mass storage from the computer or else windows install will try to use these devices as a boot drive....ok then load winxp pro or 2k install cd and boot computer from CDROM, install onto one of the drives now and your set.
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
Ok...Pat...thanks for replying...if I unhook one of the drives and install windows...should I change the BIOS back to NON RAID first? and what happens when I put the drive back in?

Codesmith...many thanks to you also! I've only just now installed w2k so theres really no reason to back it up...besides....I don't have the program to do it ...but i will get one soon.

So...do I have the steps right?

1: Unhook one of the drives

2: Change BIOS back to non raid (will this delete the array?) Or should I delete the array in the RAID BIOS first??

3: Install windows (on top of the previous installation or what?)

4: hook the drive back up


ohhhh....Techguy we must have posted at the same time. Thanks!
 

Pain

Distinguished
Jun 18, 2004
1,126
0
19,280
0
Yeah, that's pretty much it. You wouldn't necessarily have to physically remove a disk from the machine, but if it makes you fell better, OK.

The thing might be, and it depends on how you have the disks connected, but if they are on the raid controller then you will either need to move them off that controller, or you will need to configure 2 seperate arrays each with a single disk. So, in that case, it might be easier to remove one of the disks. :wink:

It sort of depends on how it's implemented on your particular board. I've seen as many different setups as I've seen different boards, if you know what I mean.
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
Ok...Pat...thanks for replying...if I unhook one of the drives and install windows...should I change the BIOS back to NON RAID first? and what happens when I put the drive back in?

Codesmith...many thanks to you also! I've only just now installed w2k so theres really no reason to back it up...besides....I don't have the program to do it ...but i will get one soon.

So...do I have the steps right?

1: Unhook one of the drives

2: Change BIOS back to non raid (will this delete the array?) Or should I delete the array in the RAID BIOS first??

3: Install windows (on top of the previous installation or what?)

4: hook the drive back up


ohhhh....Techguy we must have posted at the same time. Thanks!
Well.. it's something that I'm not sure, as sometime, with VIA, you don't need drivers at all but sometime, you need drivers..

If set as non-RAID, and the drive can be accessed by install, then you're all set, and don't need RAID. Check that. If it show IDE, then it is ok. SATA drives are IDE drives using SATA interface to the IDE controller..
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
In the BIOS it is shown as IDE or RAID. So I'm hoping I'll be able to install windows without any problems. The first time I attempted to install it was set to IDE and it wouldn't install...I believe....I'm tired and can't remember. So many things went wrong and I've tried this so many ways who knows. But, I'm not going to attempt this till monday cause I have to go out of town tomorrow for the weekend. But i'll post back when i'm done and let you all know how things went.

Thanks again for all your help!
Deb
 

Codesmith

Distinguished
Jul 6, 2003
1,375
0
19,280
0
Never install Windows with unnecessary drives connected. It takes a second to disconnect other drives and prevents a range of potential problems and mistakes.

It would be best to quickly reformat the drive before the install.

Sometimes you need to press F6 and load drivers for a particular controller even if you are not using RAID. Sometimes you need to create a single drive array even if you ar not using RAID.

For saftey it is a good idea to patch your OS before connecting to the internet.

A disk with any Service Packs and the firewall of your choice is usefull. Add the latest download from http://www.autopatcher.com/ and you don't have to worry about getting hacked before you can finish update your PC.
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
Thanks! Thats a great idea...why didn't I ever think of that!? :oops: I'm always worried when I'm doing an install that I'll get hacked before I can get it updated and the firewall installed...so you can bet your socks I'll be putting all the updates and my firewall on a cd this time. :D

Oh...and if you don't mind... exactly how do I format the drive before I install windows? I'd love to do that but I don't know how.

Deb
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
Thanks! Thats a great idea...why didn't I ever think of that!? :oops: I'm always worried when I'm doing an install that I'll get hacked before I can get it updated and the firewall installed...so you can bet your socks I'll be putting all the updates and my firewall on a cd this time. :D

Oh...and if you don't mind... exactly how do I format the drive before I install windows? I'd love to do that but I don't know how.

Deb
If you follow instruction on the install CD, you'll have the opportunity to partition and format the dive as you wish. Since there is nothing to loose at this point, explore the options proposed.
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
I went into the RAID configuration and deleted the array, rebooted and went into BIOS and set it back to IDE and it showed both drives. When it rebooted it loaded windows 2k?? (I thought deleting the array would wipe the drives clean?) But both drives are listed as the same size (80GB). I was hoping I wouldn't have to unhook the 160GB drive and reinstall windows. So what should I do now?
 

TechGuy81

Distinguished
Apr 4, 2006
16
0
18,510
0
Ok sorry it's been a while since you wrote back, I read my reply to yours and then you to me and trying to refresh my mem.
So you've deleted the array and now it gave you back the 2 drives 80 gb each instead of one 160GB raid array...you were able to boot computer but then it went back to win2k? Hmmm...yeah normally deleting or creating an array causes all info on the drives to be lost...that means one of your 80GB drives still has info on it, and a boot partition active...ok well if you want a fresh install on one of the 80GB drives and the other for backup or storage, then just change your boot drive to CD rom and boot from your win2k install CD...install win2k fresh, your current installation on the 80gb drive might be corrupt even though it started, again I'm not sure why you were still able to access it...? does this answer your question?
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
I only have 2 drives...one is 80 gig the other is 160. In windows explorer both drives are listed as 80 gigs.... And...they both are 'boot' drives in the BIOS and they both have the same exact stuff on them...windows and everything. One was setup as a mirror when they were in the array, I guess thats why both have the same things on them.

What I was wondering is this...what if I shut down, then unhook the 160 gig drive, then reboot....since both drives are boot drives with windows on them it should work shouldn't it? Would that make the 160 show up right? If not...what about this...could I format the 160 drive in explorer by right clicking on it? And maybe then I could shut down and unhook it and reboot and then shut down again and then hook it back up...would that work ya think?
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
I only have 2 drives...one is 80 gig the other is 160. In windows explorer both drives are listed as 80 gigs.... And...they both are 'boot' drives in the BIOS and they both have the same exact stuff on them...windows and everything. One was setup as a mirror when they were in the array, I guess thats why both have the same things on them.

What I was wondering is this...what if I shut down, then unhook the 160 gig drive, then reboot....since both drives are boot drives with windows on them it should work shouldn't it? Would that make the 160 show up right? If not...what about this...could I format the 160 drive in explorer by right clicking on it? And maybe then I could shut down and unhook it and reboot and then shut down again and then hook it back up...would that work ya think?
what you should do is start the installer with one drive and remove all the partition on it. once all partitions deleted, quit the installer, turn off the computer and do the same thing with the other drive.

this will clear up all the RAID metadata (bits of data that instruct the controller about the type of RAID, block size,...) and clear up the mess.

then, install the OS on the drive you want and leave the other one unplugged.. this will make sure that the OS will be correctly installed on the right drive..

everything can be done in the Installer, no need for third party application
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
Let me make sure I understand this...you're talking about the windows install disk when you say "installer"...right?
 

nobly

Distinguished
Dec 21, 2005
854
0
18,980
0
Yeah, so it was RAID 1 (mirroring).
So that means when you deleted the array, you ended up w/ 2 HDD's with 80GB each. But on one of them, you actually have 160GB, its just not showing up because of the RAID 1 array.

If its booting right into Windows w/o the RAID array, you might not need to reformat...

First I would determine which drive is the system drive.
Go to Control Panel->Admin Tools->Computer Management
Select Disk Management in the left column.
Here it will list all of your partitions.

So it'll be "Disk 0" ->shows your partitions on disk 0
"Disk 1" -> shows the partitions on disk 1
First, look for the partition with (System) labelled on it. This is the system drive. It won't let you delete the partition or do anything w/ it in Windows.
The way to tell which one is the 160GB is that the 160GB will have some unpartitioned space on there, which should show up.

Now you have to decide what to do. Do you want 1x80GB and 1x160GB partition? If so, decide which one will be your System drive.

Say you want the 80GB to be your system drive (the one w/ Windows installed). If the 80GB already is the system drive, just right-click on the 160GB partition and delete it. Then recreate one big partition of 160GB.

If the 160GB is the system drive, and you want the 80GB to be it, then I would power down the computer, swap the SATA ports on the motherboard, then reboot and hope it'll think the 80GB is the system drive on start up.

I *think* that'll work, but hopefully someone else here will read it over and agree/disagree w/ me. :)
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
Heres a screen capture of my drives.. http://whytwolf.250free.com/partitions.jpg

I guess the system partition is the 160...darn I was so hoping it would be the 80...oh well. I'd like to put windows on the 80 and have the 160 for big files like music and movies and stuff. But if you have a better suggestion on how to paritition up the drives I'd like to hear it. I'm planning on partitioning with Partition Magic after I get all this stuff cleared up and windows is right and the drives are listed right.
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
Let me make sure I understand this...you're talking about the windows install disk when you say "installer"...right?
exact.

when you choose to install the OS, you have a screen that let you create, delete partition. just use that to fix your disk
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
Heres a screen capture of my drives.. http://whytwolf.250free.com/partitions.jpg

I guess the system partition is the 160...darn I was so hoping it would be the 80...oh well. I'd like to put windows on the 80 and have the 160 for big files like music and movies and stuff. But if you have a better suggestion on how to paritition up the drives I'd like to hear it. I'm planning on partitioning with Partition Magic after I get all this stuff cleared up and windows is right and the drives are listed right.
right, the drive with 2 partition is the 160 gigs.. it end up that size to perfectly match the other drive in the array.

You could simply use the installer to wipe both partition on the 160, the install the 80 gigs alone and install the OS on it.

Once done, in the drive manager (where you capture screen come from), you can partition, format the 160 in windows once it is installed..
 

debiy55

Distinguished
Apr 20, 2006
19
0
18,510
0
A few more questions... Should I start the install with just the 160 drive hooked up when I delete the partitions on it? I should unhook the 80 gig drive first right?

And then hook up the 80 and unhook the 160 to install windows to the 80 gig drive... is that right?

Then hook up the 160 gig drive and format it in windows Disk Management.
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
A few more questions... Should I start the install with just the 160 drive hooked up when I delete the partitions on it? I should unhook the 80 gig drive first right?

And then hook up the 80 and unhook the 160 to install windows to the 80 gig drive... is that right?

Then hook up the 160 gig drive and format it in windows Disk Management.
I suggest to clear the 160 first. You'll have to use the installer for that, because the OS wont let you kill its partition ...

you don't need to install anything on the 160, simply remove the partitions

then removing it will ensure that the letter assigned to the installation drive will be C:
 

nobly

Distinguished
Dec 21, 2005
854
0
18,980
0
Running off of pure curiosity here.

Pat, do you think it would be possible for debiy55 to boot w/ only the 80GB plugged in, then plug in the 160GB after Windows boots? Since SATA is hot-swappable, wouldn't that work? heh heh, then they could clear the 160GB w/o a reinstall...
 

pat

Splendid
Jan 2, 2001
6,399
0
25,810
19
Running off of pure curiosity here.

Pat, do you think it would be possible for debiy55 to boot w/ only the 80GB plugged in, then plug in the 160GB after Windows boots? Since SATA is hot-swappable, wouldn't that work? heh heh, then they could clear the 160GB w/o a reinstall...
SATA is hot swappable, as long as the controller support it.. and VIA dont with its current controller.. So, doing so could kill something..

I think that it is best to install the OS on the 80 gigs alone, shut down the computer and install the 160 gigs..
 

nobly

Distinguished
Dec 21, 2005
854
0
18,980
0
Ah, I didn't know VIA didn't support that. Oh well.

Wouldn't the 80GB be fine though? I thought RAID 1 just mirrored the data on the drives, so the OS install, etc, would be just fine if run off of 1 HDD? Would you relaly need to reinstall everything?

Granted, it would take care of any messes that the RAID put in, but if they just wiped the 160, they should be able to run off of the 80GB w/o having to reinstall...
 

ASK THE COMMUNITY

TRENDING THREADS