May 25, 2021
4
0
10
0
Hello there,

I have been using SCP drivers to play with my ps3 controller on my PC (W10) for a long time. Recently though whenever I try to plug in my controller it does not respond, and whenever I restart and re-install the drivers through SCP it makes my mouse unresponsive until I re-plug its usb.
I have tried switching usb ports for the ps3 controller but nothing seems to be working. I have manually deleted all SCP installed drivers and its virtual bus and re-installed it again and every time I install the drivers for the ps3 controller to it, the controller lights up as if its plugged in as Controller 1 on the ps3, but stays unresponsive, and few seconds later my mouse cannot left or right click anymore, but it still tracks movement. The mouse becomes functional after I re-plug it but the controller still refuses to work.

Any idea how to make it functional again? I think these issues started slightly after I plugged in a bluetooth arcade fight stick along with my ps3 controller for the first time, but I might have also by mistake installed the ps3 drivers onto some different USB plugged in device in the SCP panel - For clarification, I have SCP disabled on start up and each time I wanted to use the controller I "installed" its drivers onto the ps3 controller again but since they were already present the service just restarted instead, and among these numerous installs I recall clicking onto something else by mistake and installing the ps3 drivers there before I promptly shut the installation off, so it might be possible I somehow installed the drivers onto my mouse? I have no clue to be fair.
 

Colif

Win 10 Master
Moderator
it doesn't help that scarlet crush hasn't been updated in about 6 years.

i doubt you installed drivers onto mouse. you may have messed windows up though.

you never install drivers to the device, windows needs them to run device though.

can you clear all the steps you have made and remove scp again and try to start from scratch?
 
May 25, 2021
4
0
10
0
I have tried uninstalling SCP completely already through its installer, I´ve also used Windows restoration point to go back a week before these issues started but neither of those seem to have helped. I have noticed though that when I install the SCP after uninstalling it I get these errors now, that were never present back when I installed it before ->

View: https://imgur.com/a/DdhjPoA


If I were to recount all the steps I took in trying to fix this it would be first manually removing all drivers SCP created by following the official guide on their page, then uninstalling it and installing it back again a few times and now finally I thought Windows restoration point could somehow revert the drivers back to before they were "corrupted" or whatever is wrong with it right now but to no avail. I also tried plugging both the PS3 controller and mouse into different USB slots but that also did nothing.

Also additional thought, now my ps3 controller has a lit up "2" as a second controller would have when plugged in whereas it was "1" before, but its still unresponsive, and whenever I re-plug it into a different usb slot or re-install the drivers onto it or restart pc and the SCP service comes on it makes my mouse unresponsive.
 
Last edited:
May 25, 2021
4
0
10
0
Additional info - I´ve switched from SCP 1.6 to 1.7 after uninstalling the first version, and while I did not get any apparent errors the ps3 controller is not popping up there for me to tune, which by the word of SCP software means its already calibrated or is faulty. I´ve hard reset the ps3 controller itself by holding down the pin in the back, my computer registers the connection of the controller, and each time its plugged in it flashes for about ten seconds before stopping, but its still completely unresponsive and no software even online seems to be detecting the controller, which is strange, because my pc does right? At the very least there is no interaction with my mouse in 1.7 SCP version, but then again it might be because I cant properly "install" the drivers onto the controller as it is not showing up in there.
 
May 25, 2021
4
0
10
0
You can delete this or lock this thread as I have solved the issue. If anyone comes upon this with a similiar issue I had to use -> https://github.com/lostindark/DriverStoreExplorer/releases/tag/v0.11.72

to get rid of the residue drivers from SCP 1.6, which I have done initially anyways, but this time SCP 1.7 picked up my PS3 controller as uncalibrated after I deleted the remnants of the 1.6 drivers and I successfully installed them in 1.7 .
 

ASK THE COMMUNITY