Question Screen blank/flicker issue with freesync

Oct 28, 2020
1
0
10
0
Hi there, I've got a Samsung Q70 55 inch display that I use with my living room setup that is hooked up to a pc using windows 10 running a Radeon RX 5700. They are connected via HDMI cable. The television is FreeSync compatible and I have FreeSync active in the settings, and also in my pc's AMD driver software I have FreeSync active.

Now games look real nice with this active, in my opinion it's a noticeable improvement on the smoothness of the framerate. However, whenever I have a game running, and I mean only a game running, whether or not it's full screen or borderless window, alt-tabbing or windows-keying away from that game will cause my display to go completely blank for a moment. It's very reminiscent of the long transition time you would experience when tabbing out of a full screen-mode game using an older monitor/graphics card where there is a difference in resolution/refresh rate. It's annoying and if I turn off FreeSync it doesn't happen. Tabbing out of the game (or in the case of borderless window, simply moving the mouse out of the game window to my other monitor and clicking) doesn't cause this to happen at all. It's seamless without the evil and corrupting influence of FreeSync.

Now this happens when my Samsung display is either at 1440p or 2160p, though I tend to run it in 1440p for more framesies. Haven't tried it on other resolutions/refresh rates. I contacted support at Samsung about this a few months ago but that ended up being a waste of time. They asked me everything they could think of about my setup and what was happening but never seemed to grasp what I was telling them and never offered a potential solution. Any of you fine individuals have any insights about this? A possible fix? I'd appreciate it. I'll include full specs below.

AMD Ryzen 5 3600
ASUS - ROG Strix X570-I Gaming
Corsair RM850x 850W PSU
16gb G.Skill DDR4 3600
Asus RX 5700-8G
Sabrent Rocket Q M.2 2280 2TB
HP EX950 M.2 2280 2TB

Samsung Q70 55"
Running at 2560 x 1440 @ 120hz, and 3840 x 2160 @ 60hz

Other monitor is an older HP 1080p monitor that doesn't have freesync/gsync and isn't part of the discussion. The Samsung exhibits this issue with or without that monitor being connected to the system. This issue has persisted through multiple versions of AMD drivers and windows updates since I built this system and bought this TV in February of this year. No other graphic or display issues are being experienced at this time.

Thanks again. Post turned out longer than I expected.

Edit: Adding more info down here in anticipation of questions I might be asked. I have windows game mode turned off. I'm not using any overlay software like streaming software, or whatever AMD's streaming/recording overlay is. I do have game mode turned on for the Samsung which I believe is required for FreeSync in the first place. AMD Drivers are 20.10.1 as of now. Windows build is 19041.572.
 
Last edited:

ASK THE COMMUNITY