Screen brightness dims when starting game

Status
Not open for further replies.
Jan 24, 2019
3
0
10
0
Need help fixing an issue where whenever I start a video game while the laptop is plugged in, the screen brightness dims. The only runaround solution is to minimize the game, take the laptop off charging, reenter the game (the screens remains dim as before) and then plug the laptop back on power - then the screen brightness goes back to the original. The graphics card on my laptop is Nvidia GTX 1070, and the operating system is Windows 10. This same issue happened once before, many months ago, and after looking it up, I found a solution to the issue by turning off adaptive brightness in display/power settings. I changed nothing afterwards, adaptive brightness is still off, but the issue just came back one day (I suspect because of a Windows or Nvidia update).
I would really appreciate help in figuring out a solution.
 
Jan 24, 2019
3
0
10
0


That was the first thing I check. At my existing power settings, on AC power, screen brightness is 75%, so neither dim or full. But I have also tried all possible combinations of screen brightness on and off AC power. Even created a new power plan that was high performance. But every time, when I start a game, the screen dims its brightness to 0%.
 

scout_03

Titan
Ambassador
then there could be a motherboard issue on power the the gpu on it very hard to tal what happens the other thing you could check if the settings is set on power saving mode ,or wait is someone that have similar laptop could have a clue .
 
Jan 24, 2019
3
0
10
0


Hmm, okay. Thanks for the help. I think I'll wait for someone who has the same problem.
 
I ran into the same thing with my new laptop. In addition to the screen dimming when running a full-screen game, it would also dim whenever I loaded a dark web page in a browser.

The culprit turned out to be Intel's new power saving options for the Intel integrated graphics. Yes I know you're using the Nvidia GPU. But on laptops with hybrid Intel + Nvidia graphics, the Intel integrated card is always on and always in control of the screen. The Nvidia GPU acts like a GPU. When a game finishes drawing a frame on the Nvidia GPU, the frame gets sent to the Intel integrated graphics, which displays it on the screen.

Open up the Windows menu in the bottom left (or hit the windows key) and search for Intel Graphics Control Panel. Once it's opened, click on Power. Then disable Power Saving Technology. That seems to be the one which auto-dims your screen even though you've disabled adaptive brightness in Windows. You may also want to disable display refresh rate switching.
 
Reactions: Re.
Aug 10, 2019
1
0
10
0
Go to device manager... search for monitor in the list right click the monitor n disable the generic pnp driver..

Your welcome
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS