Question Screen flicker Black screen and screen freeze.

Jun 20, 2021
1
0
10
0
Hello everyone!
I want to begin by explaining my issue with my current pc. The problem I have with my current system is frequently get freezing of the screen and black screens which presists for about 10-50 secounds. Usually it goes like this- I boot up a game (either Wow or Lol) i play a bit but at random times i get a freeze of the screen which allows me to hear stuff happening ingame for about 5 seconds which then results in a black screen, after 10-50 seconds The image restores but the game is unplayable because it appears as if it crashed and i have to go and manually close it down using task manager. Sometimes I have those lucky days that this issue doesnt happen as often but most of the days this happens around 6-10 times a day if I am using this pc 12 hours a day. Restarting the pc doesnt seem to help at all for that issue and those freezes happen randomly and i have not seen a pattern of them happening except , when I get into a league of legends game and this sometimes happens on the 45 second mark of the game (mostly) but can happen any time of the game.

What I have seen opening up logs:
(Display driver amdkmdag stopped responding and has successfully recovered.)

(The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user DESKTOP-POT2NTC\user SID (S-1-5-21-263877139-488503509-2963770132-1002) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.)

This began happening 1 year ago with my previous build. I replaced almost every single part of the pc excluding the case.

What I have tried so far:
-Replaced CPU
-Replaced GPU
-Replaced PSU
-Replaced and Upgraded RAM
-Replaced Motherboard
-Replaced some cables
-Upgraded Hard drives With SSDs


-Installed latest drivers for all components
-Tried different drivers for GPU
-Tried different setting for GPU
-Updated Bios
-Tried different monitor
-Connected Ethernet cable to the PC and removing flash for Wi-Fi
-installed new fans
-Updated Windows regulary
-Restarted the PC
-Remove dust regulary


My current build:
AMD Ryzen 5 2600 CPU
Seasonic S12III 650 - Non-Modular PC Power Supply - 80 PLUS Bronze - 650 Watts
ASUS AMD DUAL-RX580-O8G Radeon RX 580 OC Edition 8 GB GDDR5 PCI Express 3.0
SanDisk SSD PLUS 480 GB Sata III 2.5 Inch Internal SSD, Up to 535 MB/s
Corsair CMK8GX4M1A2400C16 Vengeance LPX 8 GB (2 x 8 GB) DDR4 2400 MHz C16 XMP 2.0 High Performance Desktop Memory Module, Black
B450M Mortar MAX

I would like to hear your feedback and any ideas of how to fix the issue i have. I feel exhausted from all of the games I have lost because of that and probably damaged my hardware. if anyone can help i would really appreciate it.
 

ASK THE COMMUNITY

TRENDING THREADS