• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Screen flickering black when connected to new 4k tv, rx580 8g

Road2insanity777

Distinguished
Feb 1, 2012
4
0
18,510
0
I am not 100% sure this is a graphics card issue but it is my suspicion. I just purchased a Samsung series 6 4k smart tv. when trying to use it as a moniter i keep getting an issue where the screen turns black for a few seconds then comes back. At 4k it seems to be happening every 10 seconds or so, less so at 2k, every minute or so, and has even happened at 1080p a couple times. It happens more frequently when trying to run games. My PC had been working perfectly on my old 1080p tv for over a year.

Sytem info:
FX-8350 Black edition
Asus M5A97 Motherboard
XFX RX580 8gig
Raidmax hybrid 2 730w PSU
16gig G.Skill Ripjaw X Series Ram (DDR3 1600)
Samsung 840 Series SSD

When loading up GTA V it changes every few seconds from the game, to black screen, to the TVs no source screen, to black, and back to the game in a constant cycle. I have it connected through a brand new 12' Monster HDMI 2.0 Cable. I updated to the latest Radeon drivers (20.2.2) with no change.

Is this setup not capable of running 4k? that was my initial though,t but the fact that it has done it at 1080p, which i know it can handle makes me question if it is a settings issue or something.

I used to know quite a bit about this kind of thing but I have very little experience with current hardware, i stopped working on computers on a regular basis shortly before win7 released. I know this system is fairly out of date but im trying to hold off building a new one until the Ryzen 4000 series comes out.

Any thoughts or advice would be greatly appreciated.

TLDR: Previously working system's screen flickers to black periodically after connecting to new 4kTV, even at same resolution as the old one,

EDIT: Solved! It was the hdmi und color setting on the tv, disabled it for my PCs input and now im 4k gaming like a carm.
 
Last edited:

Road2insanity777

Distinguished
Feb 1, 2012
4
0
18,510
0
Have you tried using a shorter cable?
Another option would be to verify that the refresh rate on your AMD software is set right.
I was originally using a 6' HDMI 1.3 cable but I thought the HDMI 1.3 might be the issue so a bought the 2.0 one, and nothing changed. I was not aware, cable length had any barring on speed. Do you think a 6' would have been better, i dont think a 3' would reach.

I have been having a hard time navigating the new UI for the AMD software and haven't found a refresh rate option yet, in the windows graphics settings its set to the default 59Hz, what would refresh rate would be considered "right"?
 
Last edited:

Jayhawker32

Honorable
Mar 5, 2015
271
0
10,960
61
I was originally using a 6' HDMI 1.3 cable but I thought the HDMI 1.3 might be the issue so a bought the 2.0 one, and nothing changed. I was not aware, cable length had any barring on speed. Do you think a 6' would have been better, i dont think a 3' would reach.

I have been having a hard time navigating the new UI for the AMD software and having found a refresh rate option yet, in the windows graphics settings its set to the default 59Hz, what would refresh rate would be considered "right"?
You will need an HDMI 2.0 cord at minimum, and it was mostly just a troubleshooting option as I've heard of some data transfer issues with longer cords. If I'm not mistaken the TV you have is a 120 Hz so 59 Hz shouldn't be causing flickering.
 

ASK THE COMMUNITY

TRENDING THREADS