[SOLVED] Screen flickering while on NVIDIA optimus fix?

Sep 16, 2021
1
0
10
0
Hi, i recently got a blade pro 17 from razer, the 2020 version.
After a few days of using, i noticed some screen flickering while the laptop was running in optimus mode, leading me to assume that the issue is on the Integrated graphics of the CPU (i7 10875h) (the graphics is intel's uhd 630), however after installing all the drivers and trying everything i still haven't resolved the issue, is there anyone that could help?
(The dedicated gpu is a 2080 super)
EDIT: The main reason why i think its a cpu integrated graphics issue is that disabling it in the device manager fixes the problem.
 
Last edited:
Hi, i recently got a blade pro 17 from razer, the 2020 version.
After a few days of using, i noticed some screen flickering while the laptop was running in optimus mode, leading me to assume that the issue is on the Integrated graphics of the CPU (i7 10875h) (the graphics is intel's uhd 630), however after installing all the drivers and trying everything i still haven't resolved the issue, is there anyone that could help?
(The dedicated gpu is a 2080 super)
EDIT: The main reason why i think its a cpu integrated graphics issue is that disabling it in the device manager fixes the problem.
I normally leave it disabled I don't use the integrated on laptops period it's so slow and annoying to deal with...
However to set it as the main and not the on board which again the same as disabling basically....

1 Right-click any blank space on the desktop and choose NVIDIA Control Panel. 2 Click Manage 3D settings, go to Preferred graphic processor, and select High-Performance NVIDIA processor and then Apply.

2 Click Manage 3D settings, go to Preferred graphic processor, and select High-Performance NVIDIA processor and then Apply.
 
Hi, i recently got a blade pro 17 from razer, the 2020 version.
After a few days of using, i noticed some screen flickering while the laptop was running in optimus mode, leading me to assume that the issue is on the Integrated graphics of the CPU (i7 10875h) (the graphics is intel's uhd 630), however after installing all the drivers and trying everything i still haven't resolved the issue, is there anyone that could help?
(The dedicated gpu is a 2080 super)
EDIT: The main reason why i think its a cpu integrated graphics issue is that disabling it in the device manager fixes the problem.
I normally leave it disabled I don't use the integrated on laptops period it's so slow and annoying to deal with...
However to set it as the main and not the on board which again the same as disabling basically....

1 Right-click any blank space on the desktop and choose NVIDIA Control Panel. 2 Click Manage 3D settings, go to Preferred graphic processor, and select High-Performance NVIDIA processor and then Apply.

2 Click Manage 3D settings, go to Preferred graphic processor, and select High-Performance NVIDIA processor and then Apply.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts