Question Screen goes black after installing amd 6670 drivers

sreeshyam4528

Prominent
Nov 5, 2018
4
0
510
0
My card is His Amd 6670
the problem is when I started my pc morning it suddenly shows black screen working good before, and when I uninstall the drivers from safe mode screen boots up and again when I tryied to install drivers screen again goes to black

1, tryed downgrading and upgrading windows 10 same problem

2, uninstalled drivers using ddu and installed fresh drivers(old version) as well as (new version) still the screen goes to black

3, also tryed updating the motherboard bios problem still not solved

4, Tryed flashing new gpu bios same problem

5, when I start the pc the boot screen characters are replacing with randam characters
example= ("Host cntrlr" shows as
"Howt Cntvlv") when connected to HDMI.

Check Image here: https://drive.google.com/file/d/18e5np2fLtkBXkzxyr3YT549x1t4-KyhZ/view?usp=drivesdk

6, And when connected to Vga shows same random characters with blue colour

Check Image here : https://drive.google.com/file/d/18kLBkOfjkC7sPY6-_GBNYN55PeGqNmPA/view?usp=drivesdk

7, and when I connect the cable with on board vga shows normal characters and normal boot screen

check Image here : https://drive.google.com/file/d/18hLu9W48DETKFika58E2B35OXPD2V_X2/view?usp=drivesdk

Os : windows 10
Motherboard : gigabyte G41
Processor : Pentium D
Ram : 8gb ddr3
Psu : Intex 500 w
 

jovan.draganovic

Prominent
Nov 27, 2018
76
1
545
4
Would be good if you could try the gpu on some other pc to se if it works there.
and also try cleaning whole pc pay attention to parts where your hardware connects.

I had exact same problem for a week and cloud not solve it and i had a two psus one my pc one for gpu and one for everything elso so when i removed one it worked again maybe this is not relevant but it helped me.
 

sreeshyam4528

Prominent
Nov 5, 2018
4
0
510
0
Would be good if you could try the gpu on some other pc to se if it works there.
and also try cleaning whole pc pay attention to parts where your hardware connects.

I had exact same problem for a week and cloud not solve it and i had a two psus one my pc one for gpu and one for everything elso so when i removed one it worked again maybe this is not relevant but it helped me.
Thanks for the reply
I've already tryed on another pc still same problem I can say that the problem is with gpu hardware but don't know what exactly causing the problem
 

jovan.draganovic

Prominent
Nov 27, 2018
76
1
545
4
Thanks for the reply
I've already tryed on another pc still same problem I can say that the problem is with gpu hardware but don't know what exactly causing the problem
well sad to say but your gpu is probably not usable anymore.
but you can get way better gpus for up to 50$ in almost any country
i recommend theese
hd 7850 30-40$
r7 270(x) 40-45$
with any of these you will double your gpu performance
 

ASK THE COMMUNITY

TRENDING THREADS