Screen Goes Black and GPU fan goes wild! HELP!

pianofreak4

Commendable
May 11, 2016
16
0
1,520
2
I just got a new EVGA GTX 1080 FTW. Shortly after I installed it i noticed that when I push the card at all (I was playing the Witcher 3) the screen goes black and the GPU fans goes crazy. The game is still running and everything (I can hear my character moving around and stuff).

I have an 850W EVGA PSU so I don't think that's the issue. Could it be the anti-surge protection on the mobo? I've heard that can be pretty finnicky at times.

I had this exact same problem before with my 770, and when I installed new BIOS it fixed the problem, it literally never happened again. I tried that again tonight and I'm still having issues. I checked all my temps and they look normal (CPU, VRM, etc.). If you have any idea what this could be please help!

Thanks :)
 

scuzzycard

Admirable
Feb 26, 2016
1,583
0
6,960
413
That's an odd one! Let us know if the BIOS update helps, because I've got no ideas except to blame the PSU, and yours is normally a good one. Then again, stranger things have happened than an EVGA PSU giving out.
 

Jay Santos

Reputable
Apr 20, 2015
294
0
4,810
24
How about other games?
Try a bench marking utility and stress test your gpu. If it survives and doesn't do what you describe, then your driver may need to be updated or rolled back.
 

pianofreak4

Commendable
May 11, 2016
16
0
1,520
2
so the fix was actually just using GEFORCE experience to optimize the game and launching it through there. Haven't had any problems since I did that.

 

Jay Santos

Reputable
Apr 20, 2015
294
0
4,810
24


It may be trying to run the game at a resolution that's not supported.
 

ASK THE COMMUNITY

TRENDING THREADS