[SOLVED] Screen Keeps Flickering Whenever I Start My PC From A ShutDown!

Oct 14, 2020
9
1
25
0
Hi Everyone. I have a VGA monitor and my GPU has only HDMI/DVI ports only. So, Last Year I bought HDMI to VGA converter and it worked fine. But Past few weeks I was experiencing some flickering whenever i start my pc after shut down. It flickers A lot, the screen (Manufacturer Logo moves lol) and after 10 seconds my monitor shows no display. And If i am lucky i can see the desktop when the pc is booted successfully. Mostly I had to restart the PC multiple times to get it working. So, I bought a new converter DVI to VGA thinking that it will fix the problem. And it worked when i plugged it in. But When I again start my PC the same problem persist. Actually, I really don't understand what is the exact issue. Tried Hard resetting my motherboard but still no fix yet.
Note: The Converters are all okay because it flickers only during boot-up. If I am lucky enough it won't flickers when i see the desktop screen and i can use the pc for hours without seeing any flickerings or blackouts.

Update: Now, It doesn't even flicker; only a blank screen with "No Signal".
 
Dec 24, 2020
2
0
10
0
Hey RealPrime
I've been having the same problem as yours a few days past now, whenever I boot up, my computer starts flickering for a good 2 minutes before it settles down, I have a Samsung 60hz monitor that's been working fine for the past 6 years or so. I have tried everything I could find on the internet, only software related issues but it seems to persist.
However if I restart my pc after use, it works fine.
I have also tested the monitor by plugging in my vga to my laptop and it works fine.
I have to mention that I'm using a vga to HDMI adapter because the gtx1070 only has HDMI and DVI.
This problem is weird and I hope I can fix it soon, I don't wanna upgrade my monitor only to have the same problem on a better monitor, what a shame.
Keep me updated if you ever find a fix. Good luck!
 
Oct 14, 2020
9
1
25
0
Hey Achraf173, The problem was with the monitor (I think) as my monitor was not able to detect them but when I boot my PC without GPU - it's good going. I literally bought 2-4 converters (HDMI TO VGA & DVI TO VGA) and returned them as my monitor was not able to detect them - Ended up buying a new monitor with DP/HDMI ports - no problems yet.
Note: It was not a faulty GPU!
 
Last edited:
Reactions: Achraf173
Dec 24, 2020
2
0
10
0
Hey RealPrime, thank you for the update.
I'm glad you managed to fix your problem as this becomes frustrating over time.
I have fixed mine as well after trying out many "solutions" that I don't even know what exactly fixed it for me. I disabled all startup programs, reinstalled gpu drivers, restored windows to an earlier date, etc.
Anyways, I'm happy it's fixed for both of us.
 

ASK THE COMMUNITY

TRENDING THREADS