Question screens fllicker off/on sometimes after loading screen

Feb 6, 2022
4
0
10
Hello!

My screens turn off for 3-5 seconds then back on, sometimes they dont display again but i can hear the application running in the background which causes me to hard reboot every time this happens. If the display comes back then my monitor is hard locked to 30-40 FPS and not 144 that I have it set to. Which also causes me to reboot, but I can do that one safely. Rarely my LEDS and AIO screen will go dark with the monitors turning off and on but it doesnt turn off all the way.. if that makes any sense.

Issue that I am having, happens after loading screens to a instanced area or anything that would cause a loading screen in games only. (so far) I've just dealt with restarting my PC when this happens and im tired of dealing with it but I have no idea what could be causing it. (This doesnt happen all the time and it seems to happen randomly) I could be gaming on WoW TBC for hours and zoning to different areas or instanced dungeons / swapping characters during that period and it would be fine and then it would randomly happen after a loading screen. Sometimes it happens right away on the first loading screen.

Games that I play a lot.
This has only happened in diablo 2 resurrected and WoW TBC Classic so far. Has NOT happened on FFXIV.
I dont play D2R anymore but i remembering it happening playing that game after loading screens.

This sounds a niche problem because I cannot find any info on this anywhere else.

Open to suggestions, but i cannot recreate the problem to see it the issue is fixed it kinda just happens when it wants too.

Edit specs:

Processor: AMD Ryzen 9 3900X 12-Core Processor 3.80 GHz
Nvidia Geforce RTX 2080 Ti Asus
32 GB RAM G.skill Trident neo
Monitors: ASUS VG27W / VG27A (both 27 in 1440p up to 144hz) Both using Display port
850W gold PSU EVGA
Motherboard: ROG STRIX B550-F GAMING (WI-FI)
 
Last edited:

Andrei N

Honorable
Feb 22, 2016
201
3
10,765
Your issue can be caused by 1. Bad PSU - the PSU cannot supply enough power to the GPU and it locks up.
2. GPU driver malfunction - I would try to solve this first.
You basically need to completely remove all drivers linked to the GPU and if the option is available - perform a factory reset of the GPU.
 

Andrei N

Honorable
Feb 22, 2016
201
3
10,765
One more thing. I saw 144 Hz as your refresh rate. Are you using dual monitors? The refresh rate needs to be the same otherwise you'll have problems.
Also is this the native refresh rate or are you forcing it on the display?
What adapter are you using? Have you tried switching adapters?
 
Feb 6, 2022
4
0
10
I have 2 monitors that run at 144 using display port I don't have the exact models but something Asus TUF gaming 27 inch 1440p one is curved other is flat. I will get the info when I get off work tonight.
 
Feb 6, 2022
4
0
10
Here are the specs

Processor: AMD Ryzen 9 3900X 12-Core Processor 3.80 GHz
Nvidia Geforce RTX 2080 Ti Asus
32 GB RAM G.skill Trident neo
Monitors: ASUS VG27W / VG27A (both 27 in 1440p up to 144hz) Both using Display port
850W gold PSU EVGA
Motherboard: ROG STRIX B550-F GAMING (WI-FI)