[SOLVED] Seagate 2TB Backup Plus Portable Drive

Jan 21, 2019
2
0
10
0
I have had my drive for about 2 years or so. It has been working fine - I went to plug it into my laptop this weekend and it didn't show up. The corner light is lit up and I can hear it working but My Computer is not reading it. I checked in Settings > Devices > Attached Devices and I can see it there no problem.

I also checked Disk Device Properties and it comes up. When I check volumes though it says Type Unknown Capactiy 0MB. Not sure why it is not coming up.

If I check My Computer it comes up as Drive E but when I try to click it or even right-click it freezes My Computer and stops responding.

I would like the data back BUT it is not the most important - If there is a way I can reset and reformat the whole drive and start fresh that is ok too. I have been googling all weekend to try to come up with the issue but everything I have found has led me nowhere. Please help!

I should also mention I have tried this on 2 different computers as well as plugging it into my TV and I get the same results.
 

travistee

Commendable
Nov 28, 2016
41
1
1,535
0
seagate support wont help you for free if you are out of warranty.

If you don't care about the data on the drive, why don't you just try to reformat it?
 

nikoskostantopoulow

Upstanding
Jan 3, 2019
170
0
210
17
My old OCZ SSD (Vertex 2) used to softbrick periodically.
It has a green led light on the back that when it softbricks it turns red.
From the internet i found info and i can confirm it's true that that drive randomly softbricks when windows put it to sleep.
Windows cannot see or read the drive but from Linux i could retrieve my data and unbrick it by formating it(light turned green again).
I am not a Linux lover but i'd give it a shoot if something similar happens to any drive of my mine again.
 

ASK THE COMMUNITY

TRENDING THREADS