Question Seagate 5TB external "Expansion Desk" hard drive works fine in another PC, but became uninitialized in my main PC

DougEFresh333

Reputable
Jan 19, 2017
36
0
4,540
1
as the title says, the external hard drive suddenly became uninitialized by my main PC sometime after installing a new SSD, or possibly after i replaced my old battery back up UPS and started using a Cyberpower 1500VA (CP1500AVRLCD ) with the USB connected to the MB via USB 3.0 slot (1 of 4). i'm using ASUS Maximus X Hero, with two M.2 SSD installed (one 500GB and one 1TB M.2), one 2TB HDD, and a new 2TB EVO SSD (all obtained one by one since 2016). i recently installed the 2TB EVO SSD, but i'm not sure exactly when the External Seagate drive became uninitialized by my PC. i believe it was after i started using the Cyberpower 1500VA Back-UPS device really. i recently had some weird issues with a small USB stick i always use, where an error popped up saying that there was a "power surge" and that there wasn't enough power to run the USB device? that only occured the one time though, and now the USB stick reads fine, but the external hard drive is still uninitialized by my main PC. the external hard drive works just fine in another PC (one i use for work), but the external hard drive still is not usable by my main PC. the external hard drive DOES appear to be detected by the computer, as it is shown in Device Manager. it also appears in Disk Management but it appears as "not initialized". i have a ton of data on this thing, so anything that would erase the data on it is NOT preferred. also, the fact that it works fine on the other PC, makes me think something is going on with the Motherboard being able to read all of these SSDs and HDDs, or possibly might have something to do with the USB 3.0 slots.

every solution i've found thus far has not worked. i've been wondering about the power issue though, where the USB didn't have enough power to start. the External Hard drive does need it's own power supply, which shouldn't cause any sort of power issue with the external hard drive, but i can't help but think there's something going on there, somehow causing the external hard drive to appear as "not initialized" to my PC because of the lack of power, or something to that affect.
  1. i have tried unplugging the battery back up USB connection, but that did not solve the issue, as the external hard drive is still detected by the PC, but not initialized in Disk Management.
  2. i have tried updating the drivers, but it says that i have the current drivers installed. i have not tried "uninstalling" the drivers and resinstalling them, because the external hard drive works fine on my work PC. that might be worth a shot though.
  3. i contacted Seagate, and used their various data recovery tools, as well as their "Seatools". and i actually did try to "initialize" the external hard drive while i was on the phone with them, and an error displayed saying that it could not be initialized, although i can't recall exactly what it said, just that it couldn't even initialize the disk (luckily, because i tried it on the work PC after this, and it worked fine).
does anyone have any ideas what the problem could be? any suggestions that does not require me to re-initialize the disk and delete all the data on it?

Thanks in Advance!!
 
Last edited by a moderator:

alanvatrox

Reputable
Aug 27, 2017
47
0
4,540
1
Have you tried a 2.0 USB port with/without the USB stick?
You could give your 2nd point a shot.
Do you have more than 1 partition, if so, when you initialized the disk, did you select the right partition and is marked as active?
Does it have a letter assigned? (You can assign a letter in Disk Management).
If it is a power issue, try unplugging a disk that you might not need for the time being and then try plugging the EHDD and see if it works.

Also, you don't have to delete any data off it since it still works on other PCs :)
 

ASK THE COMMUNITY