Question Seagate Backup Plus Slim not working anymore

Aug 21, 2019
1
0
10
0
Hi!

My Seagate Backup Plus Slim won't work anymore.

I was using my computer when all of a sudden I heard the system sound of a USB device being disconnected, and checked to see what was going on. I then found out my Seagate HDD wasn't detected in Windows Explorer. So I tried to eject it safely via Windows, and then physically pulled the USB plug. When I reconnected it I heard the system sound of a USB device being connected, but it still wouldn't show up in Windows Explorer. It shows up in Device Manager, but not Disk Management.

I've tried to install SeaTools with no luck, the drive doesn't show up there. I've tried connecting the drive to 2 other computers with the same results (one laptop running Windows 10 and a Macbook Pro running OSX). It won't show up, but it will play the USB connected/disconnected system sound. The LED light on the enclosure is on. The drive won't start spinning, but makes a weird noise (the white noise is not from the drive itself, just a bad microphone.) The sound is not loud at all, you have to put your ear really close to hear it. I do not have another cord to test with at the moment, although I did test the same cord on an older hard drive that connected just fine.

For safety I'm not keeping the drive connected in case it further damages the chances of recovery. HDD was bought about 1 year ago. Some other info, albeit not that relevant:

Computers tested on:
  • Custom rig
  • Lenovo Legion Y540
  • Macbook Pro 17" 2011
OS:
  • Windows 10
  • Mac OS X 10.11 El Capitan
I'm still under warranty, but I don't care about the drive itself, only the data on it which I'd like to recover. I'm pretty sure opening the enclosure and accessing the hard drive within will break warranty, but sending the drive back to Seagate means losing my data anyway.. Seagate does offer a recovery service which is a last resort for me, but I'd like to pursue other options before it comes to that. I'm thinking I could maybe take the hard drive out and connect it to a docking station to see if the enclosure's connectivity is the issue? Any help, suggestions and insight is deeply appreciated!

And yes, backups from now on.
 

ASK THE COMMUNITY

TRENDING THREADS