Question Seagate Expansion 2.5" Portable HDD was beeping ?

inZane86

Distinguished
Sep 27, 2012
12
0
18,510
0
Hi, hope everyone is well.

I just bought a brand new Seagate Expansion 2.5 portable usb hard drive, to make a windows to go bootable device. I plugged it in and all was fine, no errors. However when I tried running Rufus 3.14, it began the process, but at about 30% I heard two beeping sounds coming from it. At first I thought it came from outside from a car. I left it, the progress moved to 30.3% then stuck there, then I heard several more beeps.

At this point I stopped the process, and unplugged it. All the while this was going on, hdsentinel had good readings from the drive and I could access it too.
After I unplugged it, I plugged into the rear USB 3.0 port instead, accessed it instantly and am now formatting it fully.

This may seem like a dumb question but should I return it? It seems to be working, aside from that hiccup.
From what I understand this could be a usb power issue, but I dont know as I've never used a 2.5 portable on this pc before, just externals with their own dedicated power source.

Could interference from a background app have caused this? Could the usb port or cable be an issue? I'm using the cable that came with it, and no USB Hubs or additional cables.
Any help would be greatly appreciated!

EDIT: I had it plugged into the front usb, I've been told now this could be a problem. As I said I have no experience with portable drives, could this be the case?

Here is a screenshot of the HDSentinel readout:
 
Last edited:

ASK THE COMMUNITY