Question Seagate External USB portable HDD stopped working after reboot

Jun 18, 2020
1
0
10
0
Hi guys

First time posting, i tried searching for a solution first but couldn't find anything specific to my issue.

So i rebooted last night (not because of an update or anything) and when i tried booting back up the PC just hung at the bios, after 3 attempts i unplugged the External hard drive (Seagate Baracuda Expansion+ 4TB) and my pc finally booted up fine, i tried plugging the hdd back in and windows 7 pops up to say the device can work faster in a usb 3 port, and windows can see the hdd is there when i go into win+R compmgmt.msc yet windows explorer won't list the hdd in my computer.

I followed the steps on the seagate drive (clicking populate on the drive) but they didn't really say what to do with the result i got, which was

"Volume information for this disk cannot be found" (Windows states in the previous screen that the HDD is working properly)

The blue LED is still showing when i plug the hdd into a usb socket so something is still receiving power, but the drive itself doesn't sound like it's booting up (they are quiet anyway and hard to tell).

I have had other old externals develop an issue with the power board where it claims to be getting power but isn't sending it to the hard drive, but i don't really fancy breaking another out of its case if i can avoid it, especially as this one is pretty new (less than 6 months).

I have tried things like Seatools to access it and it just causes the program to hang while searching for hard drives

I have tried it on a laptop aswell, and a PS4, the PS4 wouldn't even detect it, and the laptop did the same thing as my pc "New disk detected" and then just keep telling me that without actually installing/connecting it.

Please somebody be a wizard and help me out :)

UPDATE

I borrowed a docking station from a friend and put it in there out of its enclosure, and now it's making a strange beeping sound, almost like it's singing or tapping morse code
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS